Forum » General Tuning Discussion » Haltech not hitting targets

Haltech not hitting targets

General Tuning Discussion

Discuss all things tuning in this section. News, products, problems and results. 

= Resolved threads

Page 1
Author
76 Views

Hi guys.

I am new to HPA and slowly going through the courses but I don't have the knowledge to diagnose my car just yet. I am hopping you beautiful people could assist in diagnosing my car.

Bought the car 2 months ago. It's a Nissan Stagea with a RB26DETT. Previous owner just put a fuel pump in. Not sure if it was a cheap pump and this is my root of my problems. I digress.

Car has been working perfect since purchase. I noted it was running a little rich due to soot on the rear of the car. Plan to fix this with the help of HPA.

Sadly its now running rough. I tried to check everything but found no faults MAFs, Coils, o2, TPS Vacuum leaks etc. It's popping out the exhaust and won't hold idle. Will sometimes die.

I plugged my laptop into my Haltech Platinum Pro Plug in. What I noticed was the ECU wasn't hitting any of its targets. It was running rich.

It had 3x fault codes listed.

P0172

P0175

P0171

I checked the spark plugs and the were black. I cleaned both the spark plugs and the o2 sensors but its still running rough.

Am I right in thinking I have bad injectors? (They're injectors are still factory.)

Thanks guys

First thing is when you say you 'cleaned' the lambda, how did you do it - they are very easily contaminated, or damaged, and need a specific cleaning process?

If you haven't done so, I'd recommend bookmarking, or printing, the error codes that can be found here - https://support.haltech.com/portal/en/kb/articles/diagnostic-trouble-code-dtc-index

That said, I didn't find the codes there - are you sure you wrote it correctly? Are these HALTECH or OBD2 codes you're citing?

I did find other reference to them, though.

For the P0171 - https://forums.haltech.com/viewtopic.php?t=13124

For the P0172 - https://www.s2ki.com/forums/s2000-engine-management-231/cel-haltech-pro-plug-920538/

For the P0175 - https://www.obd-codes.com/p0175

Just to confuse things, while it may have been an incorrectly set up fuelling problem, there is indeed a chance that the injectors are playing up. I don't think it's the case here, but it's possible for a fouled lambda to mis-read the oxygen content and add fuel, if there's a misfire, this is even worse because the lambda will detect oxygen in the exhaust (not used to burn the fuel because of misfire) and add fuel to try and 'correct' it.

Thanks for the reply Gord.

I just cleaned the sensor with carby cleaner. I didn't touch the sensor with my fingers because I know they are fragile. I thought if I could diagnose the o2 sensor to be the problem. I will replace it.

I saw that Haltech support page and I too couldn't find my error codes. Yes the error codes are correct and I got them from the Haltech ECU when I connected to it via my laptop.

I tried disconnecting the O2 sensor to see if anything changed. I noticed it got a little better but the exhaust was still popping. This confuses me because generally when you disconnect a O2 sensor is becomes more rich. But it being rich is more problem so I am not sure why it got a little better. Maybe the o2 sensors have gone bad and I just need to replace them.