Forum » Webinar Questions » 114 | Setting up Dash Comms - Sending a CAN message to M1 from Dash

114 | Setting up Dash Comms - Sending a CAN message to M1 from Dash

Webinar Questions

Ask questions about webinar lessons here. To see the Previous Webinars for a complete list of archives tuning webinars. 

= Resolved threads

Page 1
Author
2353 Views

Ok, so the last time I went to the track with the GPS running through the dash, to the ecu. None of the lap timing stuff worked - yay! My fault, the dash wasn't set up correctly and was still set up to receive the data from the ecu. Anyway, I have played with the car a bit since and I have it displaying lap times, and the gain/loss working.

One thing doesn't work though, the data logs do not open with the laps generated, and I have to manual generate them now. It's not a huge deal I suppose, but annoying nevertheless, more so because it was working with the GPS plugged directly into the ecu, but the ecu is getting the same information via CAN now... so I don't know why it isn't working.

To test all this stuff I have made a track between two roundabouts.

To get the lap stuff working I had to deselect the lap data in the M1_General_0x650_Version 4 comms setup

Then enable these settings

then these settings

In the ECU, I set up the following settings under the Lap tab.

From the help, my understanding that it sees beacon 1 the second time, it'll start counting laps, which will then be logged by the ecu. I suppose, I am unable to log any lap information from the dash, as I don't think I can send this back to the ecu for logging.

Anyone got any ideas? I am at the track again tomorrow, and doing practice in the morning so will try a few different settings though out the day.

Link to my dash set up: dash setup

Cheers,

Shane

Sorry I saw this too late to be of any help.

Are you getting Laptimes on the dash? If not, then perhaps you need to make sure you've chosen at least one venue in the Details Editor.

Do you have Pro Analysis enabled for the ECU? If you don't have Pro Analysis, then what workspace (Circuit, Engine, Drag or Rally) are you selecting to use (some don't do laptimes)?

I've never had lap times in the ECU log, but I am adding it to my setup now, here are some things I stumbled across:

Do you have the GPS Interface set to the correct "CAN Bus x Decode" (not the "CAN Bus x via STC")

Have you verified in GPS tune that the GPS info is being received (ie. are all the "GPS xxx" channels populated)?

What is GPS Fault Delay set to? (I suggest a large number 2000 ms)

When you go to the track, and use M1 Tune, what does the channel "Lap GPS Closest Beacon" report. It should have either one of your beacon numbers, or one of the built in XXX00 beacon numbers (273 tracks are built-in) according the the help for "Lap". Is your track listed in the built-in database?

If your track is one of the manual beacon numbers you entered, double check that you have the correct values, or change it to one of the values of GPS Latitude and GPS Longitude from your logged data.

Regarding your vehicle speed -- Does your M1 have one or more wheel speed channels connected? If so, I would use them directly in the C125 configuration for speeds and distance.

Let us know what you discover this weekend.

Hi David,

All good – wasn’t expecting anything over the weekend, Thanks for the reply. To answer your questions in order.

Yes, getting laps on the dash. I was getting laps on the dash with the gps into the ecu as well. I have been loading the Lakeside Track map, Beacon 12100.

No, no pro analysis. I have been using a Circuit workspace – I have modified it a fair bit.

Yes, I have it set to CAN Bus 1 Decode.

Yeah, I have driven around and seen the gps info in tune. Below is a screen shot of the GPS data from the weekend.

And a screen shot from when I had the GPS going to the ECU

GPS Fault is set to 1500ms, so close.

The Closet beacon wasn’t being recorded on the weekend, as in the first image above. The track is listed.

With the custom track map, I got all the GPS coords from some logs.

The ecu only has one vehicle speed sensor, which from the speed/gearbox. I shall look at putting it into the dash, but with the vehicle speed

On the weekend I tired setting the Beacon Main to 12100 for lakeside, but it didn’t do anything. I just had to generate the laps. It was a tricky day with a drying track so I ended up just driving and checking the general things after each session. Another thing I tried was changing the Corrected speed and Distance settings in i2 to just use GPS, but that didn't do anything either.

I have noticed that none of the Lap State, Number, Beacon Ticks etc populates with the current settings. With previous settings (gps into the ecu) all that information updates.

Not sure what else to try... I'm sure it'll be something silly like most of the time I can't figure something out.

Cheers,

Shane

I was out at the dirt sprints yesterday (hard clay surfaces, bulk slides, heaps of fun), and we did a few sighting laps. As I was driving around the track, I tried to "Quick Adjust" the GPS beacons (I mashed the Q button), and kept getting an error, something like "GPS not valid", I wasn't smart enough to grab a screen shot at the time. I did flick over to the GPS page though, to make sure I was getting values there - and I was. I could see Lat and Long updating, along with speed and a few of the other channels.

Anyone else seen this before? I wonder if it's a build thing.

Cheers,

Shane

You will need to send a GPS Valid signal to the M1 from the Dash to get lap timing working correctly. I have attached a screen shot of the CAN template needed to get this working.

Attached Files

Thanks Stephen!

I just had a quick look at the current settings and noticed that GPS_M1_0x682_Version 1 is already sending GPS Valid. Some of the settings seem a bit different to your screen shot. I have attached a picture of my current settings.

Will I need to make a single message for GPS valid? Or correct the channel settings.

I'll try and check the car tonight and see if what i am getting for GPS valid. I don't seem to have logged that channel.

Cheers, Shane

Attached Files

Hi Shane,

Change the channel settings to match the screen shot that I have.

Awesome, I'll give that a go. Thanks!

I tried it last night... and it didn't work. I changed the Divisor and Adder as per your image, tried both signed and unsigned, but was still getting a GPS Valid result of 0 (Unknown). I changed the offset as well, but that didn't work either :(

Attached Files

Hi Shane,

Do you want to send me your configs and I'll have a look at them for you.

That would be awesome, thanks Stephen, I have attached the latest config for my dash.... attaching didn't work...

Hopefully this dropbox link does: https://www.dropbox.com/s/4uctl2ycygtt499/Dis-plohld%20011.zip?dl=0

Cheers,

Shane

Hi Shane,

I have emailed a changed and tested config back to you, the message length was incorrect, it should have been an 8 bit number, not a 16bit number.

Thanks Stephen!

I was only out by a bit...

I didn't get to take the car for a drive last night, but I loaded up the new config you sent through and i'm now getting a "Valid" state :D and I was able to "quick adjust" beacon settings.

I might try and take it around the "test track" tonight to see if the beacons and Lap counting works.

I finally got around to testing it on the weekend and it worked! Thanks Stephen and everyone else for their help.

I set up some beacons in the ecu and the dash, to see if i could get the splits to work. They worked, but were a bit too close, so on the loop i did i would trigger 1, than 3, than 2! so the results were definitely not correct.... anyway, i'll work on that at some point. Maybe.