Sale ends todayGet 30% off any course (excluding packages)

Ends in --- --- ---

Adaptronic people! help

General Tuning Discussion

Forum Posts



Tech Articles

Discuss all things tuning in this section. News, products, problems and results. 

= Resolved threads


I am having a difficult time figuring out an issue with this engine sr20 redtop. Will you please take a look at this log and also the ECU map file.

esel008 ecu plug select.

So quick explanation of the symptom. The engine will not rev pas 5k or 55k. rpm in that range roughly. No load on engine or while driving doesn't matter. But the problem that has me stumped is the fact the when it cuts out, its not just a misfire, spudder. I hold the throttle down and when it hits that specific rpm range the engine will cut out completely, drop rpm, even if the throttle is held open. (as you can see in the log) then the engine will fall to a rpm range and then come back as if the ecu or fuel pump or something was shut off. then rev up again just fine and will continue to do the same thing over and over... will someone please look over it and see if you find something i cannot?

please input email address so that i can send to you personally as HPA site will not upload such files. the log nor the ecu map.

stock sr20

raywire engine harness.

using internal map sensor on the ecu.

stock coil pack / stock ignitor

timing has been locked and set.

if you zip the files you can upload them. I'm sure the tech guys on the site will be able to allow the file extensions if you post them up

ok i got it thanks chris250. Hope this works out and someone is able to find something I may have missed or setup wrong...

this includes a driving log and a no driving log and the map file.


Attached Files


do you have still the problem? I took a look at your log, but there are a log of values "empty". I read that you use the internal map sensor of the select ecu, but the MAP values in the log are empty?

Is the timing still locked after adjusting it?



Hey Bastian,

Yes I did figure it actually. All I had to do was upload a fresh firmware into the ecu and a fresh base map from adaptronic. And it has solved the issue.

That's a strange find you have there. The adaptronic tech and I didn't catch that. Not sure what that's all about. But damn good eye haha. Thanks for your input and time into looking at the problem I had. But a simple restart of everything solved the stupid problem.


We usually reply within 12hrs (often sooner)

Need Help?

Need help choosing a course?

Experiencing website difficulties?

Or need to contact us for any other reason?