Sale ends todayGet 30% off any course (excluding packages)

Ends in --- --- ---

Connect a racegrade tc8 to link g4 thunder via can

General Tuning Discussion

Forum Posts



Tech Articles

Discuss all things tuning in this section. News, products, problems and results. 

= Resolved threads


As the the title states above im trying to pair my racegrade egt box with my link g4 thunder im new to the can bus thing and am having trouble getting it to hook up and stream any help would be greatly appreciated

- Do you have power to the TC-8?

- Are the CAN Hi and CAN Lo (sometimes called CAN+ and CAN-) connected?

- Do you have at least one terminating resistor (100 - 120 ohm 1/4 watt is ok) at the end of your CAN bus. The spec says two are required, one at each end of the bus, often if only two devices are connected a single resistor is sufficient (and required!).

- Have you configured the Link G4 Thunder for 1Mbit/sec CAN operation? (or configured the TC-8 to operate at another CAN rate -- not likely).

- Is your problem how to configure the CAN addresses in the Link G4?

Beyond the physical connection which David has covered above, you'll need to configure a template to receive the data from the TC8 which you can do under the 'ECU Controls -> CAN Setup' drop down menu.

I haven't used a TC8 however it looks like they emulate the E888 CAN stream and the Link G4+ is able to receive an E888 as a default option. To receive this data you'll need to set your CAN configuration to User Defined for the relevant CAN bus and set the Bit Rate to 1 Mbit/s. Now under data you can select Channel 1 and set it to 'Receive MoTeC E888'. The default address is 0x0F0 which is 240 in decimal. You'll need to enter this as the address ID.

Thanks for responses lads ..im just flying a little blind as ive never played with can bus stuff ..thanks andre i will give that a shot tonight

I have done all the above which is what i did b4 but still no display

If you put an oscilloscope on the CAN Hi & CAN Lo, do you see the signals indicating traffic? If not, check your wiring at the TC8 connector.

If there is traffic, but you are still not receiving it, try swapping CAN Hi & CAN Lo (it's easy to get these backwards sometimes). If that doesn't fix it, put it back as you originally wired it!

Do you have any other CAN receiving device that could be configured with some diagnostics? (like a MoTeC dash? or the MoTeC UTC use their CAN Inspector software).

You can also use the Link Runtimes screen to see some basic CAN troubleshooting info. Press F12 or "R" key to open up the runtimes screen, scroll across to the CAN tab. If you have a nice block of green like below that will at least confirm wiring/termination, bit rate and CAN ID are correct.

Hi thanks i have done the above and all is good just no stream

To confirm there is active comms, If you disconnect one of the CAN wires, do you then get red errors in the runtimes?

When i get home later i will check

No error if u disconnect

Am i missing some set up in the ecu or something ...

It sure seems that way. can you attach your map so I can take a look. Are you using the round 6pin CAN port or the CAN wires on the D connector?


sorry to get back late

the problem was that format was on extended

And not normal.

but when i checked wires etc i manage to hurt the pin connector :( (hs pin):(

fixed that and now its working.

thanks for all help


Awesome, great to hear Kim. I've been in that situation before also (making another problem while trying to fix an existing one) and it can really leave you chasing your own tail!

We usually reply within 12hrs (often sooner)

Need Help?

Need help choosing a course?

Experiencing website difficulties?

Or need to contact us for any other reason?