Sale ends todayGet 30% off any course (excluding packages)

Ends in --- --- ---

Misfire/hesitation issues after a while Link G4+ PNP Mazda GTX BPT engine

General Tuning Discussion

Forum Posts



Tech Articles

Discuss all things tuning in this section. News, products, problems and results. 

= Resolved threads



I am experiencing misfire problems when I run the car for about 30 minutes with light load.

The car is a Mazda GTX BPT 1.8 Turbo fully stock engine.

To give you background of all I did to make sure everything is ok before pointing fingers to the ECU.

1) New DW fuel pump. Pressure checked

2) New DW 450cc injectors

3) New cap, rotor and leads

3) New coil

4) New ignition module

5) New OEM recommended NGK spark plugs

6) Factory loom removed from the car and repair broken connectors and cables

7) Link CAN Lambda

8) Setup proper trigger system configuration on the ECU

9) Engine Compression tested 170 PSI all 4 cylinders

About the tune the IAT that I am using is the one located at the factory AFM. But the IAT correction is disabled. The only thing enabled is the Open Loop Correction which I think I am going to disable that also to start with the basics. I am using the Traditional mode.

Still after I run the car for a while like 30 minutes of normal driving, the car starts with hesitation and misfire issues even a light load. It feels like the car was not getting fuel. I checked the fuel pressure at that moment and it was good.

So I made a data log at the moment the car started with the hesitation and misfire. I noticed at that moment the duty cycle of the injectors was low for the TPS position which tells me like a fueling issue.

But what is strange is this starts to happen after a while with no changes whatsoever in the tune after 30 minutes of normal driving more or less. If I leave the car to cool a little bit for while the hesitation and misfire is not present but after 5 to 10 minutes it starts again.

To be honest I am getting tired of this situation. I have been chasing this issue for a while, double checked and replaced everything that could cause this issue outside the ECU, with no success. Again we are talking about a fully stock engine nothing fancy.

The last thing is the ECU that could be causing this.

I ask Link tech support multiple times and to be honest the answers are very vague.

This is the first time that I am using Link and its not looking good for me.

Tune and logs attached.

Please advise.


Attached Files

You need to understand what compensations (or trims) are being applied to the fueling. It could be a background air temperature compensation, or an engine coolant temp compensation, or even a safety system that adds fuel when knock is detected.

In your logging, pay attention to the operating conditions when the engine is running well, hitting target Lambda in open loop, or with small trims in closed loop. Then compare that to your later conditions -- what is different? Whatever is different is a clue as to what compensation needs to be tuned.

This is a problem that many inexperienced tuners make -- normally you should only change the fuel map when the vehicle is in normal operating conditions, Once that is done, most tuning happens in the compensation tables to account for conditions that weren't the same when tuning.

I understand the Link has good tools to deal with charge temperature compensations, and that's likely to be critical with a turbocharged engine. I think you might find this webinar useful:


Greetings David,

Thanks for the feedback.

I understand that I have to tune the fuel map in normal operating conditions and then apply corrections based on different conditions. That is why I disabled every corrections that the ECU could apply so I can focus to tune well the fuel map. The only one that is active is Open Loop Correction which I will going to disable that also to see what happens.

But if the tune is the problem to be honest this ECU is giving me a hard time as this is the first time I am exposed to Link. With other ECUs that I worked before (Haltech and Microtech specially) I never experienced this kind of issue on the same engine.

I will look at that webinar to see if that helps.


What do these logs represent? Is it missing in one log and not in the other? The measured lambda looks terrible in both of them - that suggests it is missing in both?. If it is missing in both logs, then can you attach another log with the engine running ok.

3.5ms of dwell seems a lot for a distributor engine, is the coil getting hot? Try it at more like 2ms.

Greetings Adam,

I will attach a log when the engine is running fine before the issue.

The 3.5 ms of dwell comes in the base map for the GTX.

Like wise other ECUs that I worked before also comes with the dwell at 3.5ms.

I will reduce it to 2ms as suggested.



I reduced the dwell to 2.0ms.

Again same issue no difference. When its start to happening I increase fuel to see if that make a difference and same thing.

I disabled Open Loop correction also.

What else to look?

It looks something is messing up when it gets heat soak for a while.

I will post a log later when the car runs fine.


We usually reply within 12hrs (often sooner)

Need Help?

Need help choosing a course?

Experiencing website difficulties?

Or need to contact us for any other reason?