Sale ends todayGet 30% off any course (excluding packages)

Ends in --- --- ---

car behaves weird after after spirited driving

General Tuning Discussion

Forum Posts



Tech Articles

Discuss all things tuning in this section. News, products, problems and results. 

= Resolved threads


good day,

i have link g4+ xtreme powering an sr20vet build. i keep getting a strange/crazy fuel problem when i drive the car and come to a stop. it usually goes very lean. the closed loop lambda would add the maximum set 15% and it would still register lambda 1.2. on a normal some times it stalls and wouldn't start back. for me to get it to start i would end up maxing the VE in the idle are to 150 just to get it fired up. that still woundn't reign the afr in to lambda 1 it would still read lean (lambda 1.2). by this time i would have to hold the rpm up the pedal to keep the car from stalling. sometimes i would get alot of afr swings from lambda 1.2 to lambda .7 back and forth. thinking this is closed loop lambda creating a problem i would then disable it.

I am using an AEM x series wideband gauge and using the 5V out and the ground out connected to and analogue input and sensor ground. what i did observe is that when the car is having its crazy issue afr reading on the gauge and on the link software does not match.

finally after adding all the possible fuel i can add in the main fuel map, taking off closed loop lambda the car would respond after a while (between 5 -15 minutes) and start idling very rich. this would prompt me to reverse ALL the changes made the car would be back to its original map.

has anyone experienced this before. i added the calibration that i am using and a log of both a normal situation and the crazy situation .

with the crazy idle log i increased the ve between -100kpa to 0kpa and 0rpm to 2000rpm to 150 then i disabled the closed loop lambda after some time it regularized and i reversed the both changes

Attached Files

Could it be some weird heat soak problem? It's not uncommon when there are significant under-bonnet changes.

Bit of a long shot, but is it possible the radiator fan (or other electrical device) is operating and causing voltage variations that is throwing the ECU/sensor values out - that the two lambdas don't agree suggests that, and don't forget the ground side? Easily checked by unplugging it, momentarily, and seeing if that makes a difference?

Sounds like a ground/ground loop issue, make sure your sensor grounds aren't seeing return current from loads, ideally you would be taking lambda signal into the ecu via digital signal such as can or serial to reduce such problems. Chech all your wiring.

thanks Gord and Slides for the responses. I'll troubleshoot as you both said.

I tried for all my power grounds (CAS, Ignition coils, ecu power grounds, and the power grounds for the gauges as most of them i'm using their 5V out, also the 2 grounds from the main and enabled relay) to go individually to the head at one single point. then i have an earth strap from the engine to the chassis and from the battery negative to the chassis. what i don't have and will be adding is a earth strap from the engine to the battery negative as recommended in the practical wiring course.

the engine fan is grounded to the chassis and the fuel pump is grounded to the chassis.

the sensor grounds are spliced together at the ecu header along with the shielded wire grounds. but I'll double check all the wires today to make sure.

thanks alot guys. i appreciate the insight and guidance

You may still be seeing effects from fuel or intake manifold temperature genuinely effecting fuelling too but you obviously need the ecu and guage following each other before you can dig into anything else.

It seems you are using several different grounds, connected in different places - there is a phenomena called "ground loops" where there can be slightly different voltage potentials at different points of a ground network. The same principle applies to voltage/current sources - where possible, it is generally a good idea to use common ground and power points for all electronic devices on the same EWCU, or device.

It doesn't explain your current problem, but may be something to watch for in the future.

i think i got the problem solved.

Gord, Slides thanks for your advice it sent me down a path that i think solved the issue.

while the car was misbehaving i shook the engine harness and the issue cleared up. i then started troubleshooting the harness starting with the signal wires, sensor grounds and the power grounds. they checked out good. i then moved to the power wires and there was my problem. the power wire for the injectors had an issue. i have a single power wire coming to a deutsch connector with the signal wires and the after the connector the power wire would break out into 4 individual wires to the injector connectors. At the deutsch connector the single power wire pin didn't lock in the connector properly (my error) and it walked back down the connector. it was barely making contact and i wasn't getting good continuity. i repaired it. car fired up smoothly. I shook the harness like a crazy and everything held up rock solid. going for a drive tomorrow to see if its really solved.

Cool, and in the unlikely event it's still playing up, you have the confidence you have eliminates several other possible causes.

We usually reply within 12hrs (often sooner)

Need Help?

Need help choosing a course?

Experiencing website difficulties?

Or need to contact us for any other reason?