×

Sale ends todayGet 30% off any course (excluding packages)

Ends in --- --- ---

Having Issues Starting my BMW 2JZ GTE VVTi running Haltech Elite 750

Off Topic Discussion

Forum Posts

Courses

Blog

Tech Articles

If it's not really about tuning or wiring. Then it belongs in here.

= Resolved threads

Author
865 Views

Hi Guys, I'm facing some issues with my Car, I will tell the whole story here, maybe you can help me.

The Car was running Fine, I stopped the Car, striped the engine, to put some new Pistons, Rods and bearings, full rebuild, and paint the engine Bay.. didn't touch the Harness, just unplugged the Plugs from the sensors..

I've put back the Engine on the Car, the Car doesn't, Start, after a little while, the car started but feels like working on 4 Cylinders only, and has no Idle, and is throwing Fuel from the exhaust.

I tested Spark on all Coils, it has, all injectors are spraying, the Timing on the Car is fine...

It feels like the Car is throwing spark on the spark plugs on the wrong time..

Is it possible that the ECU burned something inside, or what it could be, Im kinda Lost here..

Thank You

Did you get overspray into any of the electrical connectors while painting the engine bay. Have you scraped paint away from any ground studs to make sure there is a good chassis ground?

I didn't Get any over spray, I have good ground to the Car, I even tried to Put a complete new Wiring Harness with the Elite 2500, with new IGN 1A coils, to see maybe the problem is with Coils or the Wiring Harness from the Elite 750 that's on the Car..

But Still having the same Issue, 5th and 6th Cylinder are not Burning, when i take out the spark plugs, they are wet, but the other 4 are black and dry.

When I test the spark outside on the 5th and 6th coil, they do have Spark..

I am really Lost here..

Do cylinder 5 and 6 have compression?

I will test Compression on Monday, and I’ll let you know.

Thank You

Hi there, I've tested Compression, all Cylinders Have Compression, I tested Timing on every coil, timing is on 15º..

I really don't Know what to see next, the car still not working 5th and 6th cylinder, I even took out the Exhaust and Intake manifolds to see if there is anything blocking there, and nothing..

Have you checked that timing belt is set correctly?

Also you said there is no spark in two cylinders. Have you confirmed it with spark plugs out of the block?

Yes I did check the Timing Belt, is set correctly, I did it using My Knowledge, double checked using the 2JZ user manual, and did it using a screwdriver to check TDC.. It is 100% correct..

When I take the spark plugs outside the block, they do have Spark, I even tested if the spark is same with the other Coils, I put some fuel on the sparkplug, and cranked, the light up the same way...

But when the spark plugs are in the block, and I start the Car, the Car Works roughly, and when I pull Out 5th and 6th Plugs, they are clean and wet with fuel, meaning that they are not Burning...

What is AFR when engine is running roughly?

Silly question, probably, but is there any chance the plugs for 5 & 6's coils or injectors were mixed up?

I'm suggesting that because everything else seems to check out OK.

I'll toss in another potential simple one, are the injectors on 5 and 6 the same size and type as the other 4?

Hi, The AFR is at 0.8 Lambda more or less, No the injectors and Coils were not mixed up, because I even tried mixing them to see what happens.

Yes All the injectors are same size as the other 4..

With that rich, perhaps your issue is increased fuel pressure. Could the fuel pressure regulator be plumbed backwards (I've done that...)

What do you mean exactly by plumbed backwards??

I’m asking it, because something weird happened, I Didn’t removed the fuel pressure regulator from the Car, nor the Hoses, when i assembled the engine, the Fuel pressure was on 6 Bar, alone, nobody touched the Regulator Screw… but before I took out the engine the Regulator was on 3 bar.. That was weird.

In my case, I think I had the fuel rail / pump connected to the return port, and the inlet port was returning to the tank.

In your case, perhaps someone kinked / restricted the return hose, causing the pressure rise. Have you reset the fuel pressure?

Double the fuel pressure would explain your extremely rich AFR at idle, and possibly the 2 cylinders of misfires.

I'll try and check all the fuel lines if has anything blocking it.

But, when I realised that it was on 6bar I reduced to 3 bar on the screw, but still not working 5th and 6th cylinder, when I take ou the plug is completetly wet with fuel, I checked the Oil now, and the oil is mixed with as well.

Perhaps your high fuel pressure has caused an injector to stick open.

After that, I Changed the Injectors…

Hi, again 😅..

I was testing the compression Again on the Engine, and I Got 10 Kpa x100... While my pistons are 9:1..

Could it be the problem ?

Normally compression is 1.3-1.4 times higher than compression ratio on a hot engine...

Hmmm, about the only thing I can think of is there's a bad connection or pushed back pin in the rear connectors?

DO NOT think the reported AFR is accurate, BTW, as if the oxygen isn't being used to burn the fuel that's going to be picked up as free oxygen by the lambda, which is going to give a much leaner indication than the four running are actually running at.

I assume you're using fresh spark plugs, each test, in 5 & 6, but have you been cranking the engine with plugs out and injectors shut off, to flush out the rear cylinders with fresh air and get rid of the fuel that may be sitting in them? If you have an air-line, use that to blow air into the cylinder through the plug hole for a while, to clean the fuel out - back in the day I used a spare nozzle with a length of brake pipe brazed to the nozzle for this - a spare because most of the time it's a nuisance, but the extension was also be useful for other times, when the stock tip just couldn't get into the places I needed it.

I'm suggesting that because it's possible the fuel residue is making those cylinders too rich to ignite, repeating the cycle of mis-firing.

Hi Gord,

I don't think I have a bad connector, because when I test the injectors and the coils, they all work when I crank, Coils have spark, Injectors are spraying evenly, and just to make sure, I've connected everything with a new harness from haltech, new ECU, new Coils, New injectors, and kept doing the same.

The lambda is sitting at 0.50, I tested yesterday.

Yes, I'm using fresh sparkplugs, I tried cleaning the cylinders, I tried cranking withou the spark to shoot all the fuel that was there, then I blew it with air, and leave it open until the other day, All the fuel that was there, went down to the sump, changed oil, and tried again, is doing the same thing..

Lambda 0.5 is SUPER rich*, especially as there should be the unused oxygen from the mis-fire biasing it to a false lean.

Might be a good idea to try pulling a bunch of fuel out of it, while you're trying to get it running better?

*https://ftyracing.com/tech/lambda-afr-table/

Tomorrow, I'll try and take out the cylinder head, and put it on another Engine, and see if it does the same..

I'd check the lambda is working accurately and pull a bunch of fuel before going to that hassle and expense.

We usually reply within 12hrs (often sooner)

Need Help?

Need help choosing a course?

Experiencing website difficulties?

Or need to contact us for any other reason?