×

Sale ends todayGet 30% off any course (excluding packages)

Ends in --- --- ---

duty cycle works backwardes

Boost Control

Forum Posts

Courses

Blog

Tech Articles

Discussion and questions related to the course Boost Control

= Resolved threads

Author
1445 Views

Hi, i have a question? i have a haltech platinum pro ecu and i have problem with boost control.

my duty cycle works backwardes. and i want to know if i cant change it around?

And my openloop works but close loop does`t ,

That suggests your solenoid is plumbed incorrectly. Are you using a mac valve? how is it connected?

Yes i'm using a mac 4 port boost solenoid and it's plumbed in the car oem solenoid harness.

I did switch the wire of the solenoid around but it stay the same

As i increase duty cycle the boost drop off and when i decrease duty cycle boost increased

Yes, I understand what you mean, I wasnt asking about wiring, I want to know how the hoses are connected to the ports and wastegate. Give us a drawing or note down which port is connected to what. it sounds like you have the NO/NC ports swapped.

Solenoid ex port to atmosphere

Solenoid in to the turbo pressure

Solenoid A port to the top of the wastergate port

Solenoid b port bottom wastegate port

As said above, sounds like you’ve got the plumbing of the vac lines the other way round, however your example above seems ok.

Can you change the wastegate control mode in the ecu? I.e can you set it to Bleed On or Bleed off? This will also cause the same symptoms

Michael,

did you by any chance solve your issue, I am having a very similar issue. Hoping on your advice with this..

We usually reply within 12hrs (often sooner)

Need Help?

Need help choosing a course?

Experiencing website difficulties?

Or need to contact us for any other reason?