Sale ends todayGet 30% off any course (excluding packages)

Ends in --- --- ---

Open Loop Boost Control Motec M84

Boost Control

Forum Posts



Tech Articles

Discussion and questions related to the course Boost Control

= Resolved threads


Hello all,

Looking for some help. I can't seem to figure this out. I was on the dyno on Friday for the first time with this setup. We finished our wastegate spring pressure runs and decided to start to turn up the boost. I had entered values as high as high as 32% on the dyno and the boost remained at 180kpa, my spring pressure.

Rechecked the plumbing side of the 3-port and all us plumbed correctly.

I packed up and went home. Once I got the car home I was able to take a deeper dive in to the software.

The boost controller is wired in to Aux 4 which I tested through the output testing of the Motec ECU Manager and the boost solenoid pulsed as normal. The only possible issue I found was for whatever reason in the Boost Control Setup, in the controller channel I had set 1 or 0 (can't remember which) which should have been set to 6 "None (Duty Cycle Control Only).

As the car is loud, up pipe hood exit, it is virtually to try and hear if the solenoid is pulsing with the car idling. Instead, I tried with only the power and ignition on, set values in the AIM table such as; 30, 40, 50% duty and was not able to get the solenoid to pulse. I tried this with the X-axis set to RPM (from 0-5000) and it did not pulse the solenoid. I also, unchecked the X-Axis and tried it with the Y-axis set to TPS (from 0-50%) and still nothing.

My first question is will the solenoid pulse if the computer doesn't see RPM as I did with the test above? On another setup with Haltech, if I set any duty cycle to say 30% on a table with 0 RPM or 0% TPS, the solenoid will pulse. I could not get this to happen with the Motec.

I've attached a picture that demonstrates my next point. In the Motec software you can see it's commanding a set duty percentage (circled in picture with dial gauges) yet the Aux 4 Duty Cycle remains at 0% (also circled in picture). This to me seem looks to be my problem. I just don't know why it's doing that.

I've attached some screenshots with the current settings and some live data. Any ideas? Do I have something set wrong?

Attached Files

Do you have power being supplied to the solenoid and the M84 is grounding the signal?

What is the Boost Normal Position set to?

What are the Boost Min/Max Duty values?

If you change the Polarity of the Aux Out, Does this get the solenoid working?

- 12v being supplied the the solenoid and the M84 is grounding. Confirmed with a meter and also was able to pulse the solenoid using the '"Test Outputs" in the M84.

- Boost Normal position is 0.

- Min 0% Max 100%

- Changing the polarity makes a single click, almost like the valve completely swings to the other side. It does it both ways.

To get the boost working correctly in Open loop you need to build up the Normal Position Table, this is the feed forward table for the boost control system (the difference between Open and Closed loop operation is that the PID has been enabled on top of the Normal Position table). The Normal Position (Feed Forward) table is used by the M84 to apply the correct amount of Duty Cycle to the Boost Control Solenoid for the boost level that you want, if the is set to 0, then that is what will be used to drive the solenoid.

If the Solenoid is at 0 constantly in the boost region, but you are not seeing boost going over the wastegate spring, then it sounds like the solenoid has been plumbed so that there is no supply of manifold pressure to the top of the gate to keep it closed, this means that you will likely need to have larger DC numbers to build boost, and then lower numbers to bleed it off, changing the Polarity will invert this if you want.

Hi Stephen,

Thank you for your reply.

When testing, can this be done without the car running and only in the on position OR does the M84 have to see rpm signal to start working boost control? I have not tried the normal position table as your suggestion yet but so far I have been unsuccessful in even getting the solenoid to pulse other than in the test output function.

I will review the normal position table. In the F1 Help for this table, it says the integral clamps need to be set. I'm assuming that's only if I use the PID function correct? I will be running this car in open loop.

As for the plumbing, I just had a look again now and it's plumbed as follows: Pressure from the compressor teed in to Port 1 of the solenoid and in to the bottom of the gates. Port 2 vented. Port 3 to the top of the gates.

Hello Michael !

Happy to know you got your car on the dyno!

If I remember my gold boxes days you need to check with the activation pressure if you want to see some DC on the solenoid. Having this set to 110 KPA means it will de-activate the control under 110kpa.

Hope this helps !

Hi Charles,

Nice to see you here! You are correct about the activation pressure on the gold boxes. I did however try that. I've done 75pka, 0kpa, and nothing. I'm completely stumped at this point.


I tried the normal position table with several different values and nothing changed. Again this is assuming the solenoid would pulse without the car running. A little later today I'm going to fire it up, hold the solenoid in my hand and see if I can feel it pulsing.

Hi Michael,

Have you looked at the MoTeC Gold Box webinars on setting up Open Loop Boost Control?

They also have one for Closed Loop Part 1 and Part 2

I wouldn't expect the boost control to be active unless the engine was running. Why would you expect it to work? if you just want to test the wiring, that is what test outputs is for. Sounds like you've proved it's wired correctly.

Hi Stephen,

Yes I have. For this reason I'm stumped. I've followed them to the T.


The only reason I'd expect it to work is that some systems I've used in the past, IE: Haltech, the boost solenoid will pulse/cycle with the key on if a condition is met. As an example at 0% TPS command 20% DC.

The reason why I would want to do such a thing is that in my case the car is not a street car. It has to be trailered to the dyno to verify the controller is working. I would hate to waste the time and money of diagnosing an incorrect parameter on the dyno when I could simply perform this in my home garage. My thoughts are if it doesn't pulse at home it's not going to on the dyno so figure out why is it not working before wasting any more dyno time. Also, the car is too loud for me to hear the solenoid at idling.

My next step would be to idle the car and have parameters set that would activate the controller and by touch see if I could feel the solenoid pulsing. If that doesn't work, I don't know what else to do.

Hi all,

Firs off thank you everyone for your input and help. This has helped me find what I believed to be the problem. I will share in case anyone has the same problem.

My 1st Mistake:

When I had got home from the dyno I discovered I had input the Controlled Channel incorrectly in the Motec M84 software under the boost setup. I had it set as 0, which is MAP. Instead it had to be set to 6 for open loop duty cycle. (See pic).

My 2nd Mistake:

Once I corrected and changed this parameter, I tried to test the boost control by having power/ignition on but not the engine running. I assumed testing like this (I was wrong) would work. No matter what setting or setup I tried, the boost solenoid would just not pulse. Once I fired the car the solenoid immediately started to work. The Motec M84 will not do any boost controlling unless the ECU is seeing RPM which I believe David was trying to tell me above. Now I can't say if it only has to see RPM like on cranking or it if has to run but we get the idea.

Thank you again everyone.

Attached Files

You can touch it if you wish, but you could also just view the channel Aux Out X Duty Cycle. I bet you'll find it reads zero when the engine isn't running, and follows your normal position as you free-rev your engine in the shop. Do you have RPM on one of the axis of the Normal Position Table?

We usually reply within 12hrs (often sooner)

Need Help?

Need help choosing a course?

Experiencing website difficulties?

Or need to contact us for any other reason?