×

Sale ends todayGet 30% off any course (excluding packages)

Ends in --- --- ---

AEM Infinity Series 5 13B trailing coil firing randomly

EFI Wiring Fundamentals

Forum Posts

Courses

Blog

Tech Articles

Discussion and questions related to the course Motorsport Wiring Fundamentals

= Resolved threads

Author
298 Views

Hey all, trying to diagnose a weird issue on a 13B FC rx7. I wired this car like 4 years ago and it has been fine until the motor cracked a rotor. Was rebuilt, put back in and broken in. Tuner found on the dyno that the trailing coils were still firing even when disabled and stopped the tune.

He locked the file so I can't see anything useful on the ecu besides the ability to disable individual coils.

Car has an AEM series 5 Infinity ecu, IGN-1A coils, and the usual other rotary things. Coils are mounted near the brake booster and have leads to the plugs. IGN-1A's were wired correctly, grounding to each rotor housing and sensor ground back to the ECU on pin 23. I have just finished checking all the small things, like tight grounds etc when the engine was re-installed.

I have attached oscilloscope screen grabs from testing.

'13B blue-lead yellow-trail (both coils enabled, normal)'

Blue channel is back probed to the lead coil's ecu output at the coil's connector. Yellow is the same. Nice square wave, what I expected to see for lead/trailing split and even dwell times.

'13B blue-lead yellow-trail (trail disabled) long dwell'

same as above but in the AEM software the coil #3 and #4 are disabled. its completely intermittent and the dwell time varies all over the place, I happened to get a grab of a 25-30ms ish dwell time signal.

This car nuked a coil on the dyno when the tuner stopped, which they replaced and I can see why now.

The signal is so square and similar to an actual trigger event I am really doubting the tuner's theory of some kind of 'interference in the wiring' causing this. I'd expect to see more noise in the signal or a rounded wave vs this really square and pronounced. I don't have a lot of trust in AEM hardware but before I make a call and send it in for repair and have to battle their tech support and have the car down for 2 months I am curious if anyone else has seen this before.

Attached Files
  • 13B-blue-lead-yellow-trail-both-coils-enabled-normal-2.bmp
  • Attachments may only be downloaded by paid Gold members. Read more about becoming a Gold member here.

  • 13B-blue-lead-yellow-trail-both-coils-enabled-normal.bmp
  • Attachments may only be downloaded by paid Gold members. Read more about becoming a Gold member here.

  • 13B-blue-lead-yellow-trail-trail-disabled-long-dwell.bmp
  • Attachments may only be downloaded by paid Gold members. Read more about becoming a Gold member here.

I think if you're going to disable the coil you should also disconnect it. Do you intend to run the engine normally with the coil disabled?

Probably one of two things :

Perhaps a disabled output has an undefined state, and sometimes (say depending on the state of other outputs) it could be charging the coil constantly.

Or some internal ECU bug that they will likely never fix.

I get the same result with the connector unplugged.

Both sound like something I can't fix lol.

These are the conditions that the tuner left me with to diagnose, from what I know he was having some kind of trouble on the dyno and start diagnosing the ignition system, disabled the trailing coils and got zapped. But what you're saying sounds totally reasonable and fits the symptoms. The ignition coil that was damaged was after the trailing coils were disabled.

Seeing the scope of 'normal running' I'm not even sure there's an issue here honestly...

Attached Files
  • 13B-blue-lead-yellow-trail-trail-unplugged.bmp
  • Attachments may only be downloaded by paid Gold members. Read more about becoming a Gold member here.

I don't understand how a coil can fire if it's not connected? That is the result you care about.

The state of an output pin that is not connected is measured in milli-give-a-shits as far as I'm concerned.

The coil doesn't fire when its not connected.

The scope traces are the trigger wire between the ecu and the coil connector and the trace's look the same whether its plugged in or not.

Like the ecu is still trying to fire the coil when its disabled, but as you've already suggested that's probably a bug in the AEM.

the issue is when the output is disabled it melts ignition coils, making the tuner think that its doing this under load at rpm

Tried with the scope on the ecu side, same result. Tried disconnecting the trigger wire and connecting just the probe, same results.

Tried scoping an unused ignition output (coil #6, for some reason rotary mode uses 1,2,4,5 in 2 rotor) and to my surprise this output is pulsing as if it were a 3 rotor and disabling gets the same result.

This rules out a wiring issue.

I think I am going to wrap this up with it just being an AEM thing. When the coils are all enabled they behave correctly. The diagnostic feature that is being able to disable an ignition output appears to be somewhat useless and dangerous for ignition coils.

We usually reply within 12hrs (often sooner)

Need Help?

Need help choosing a course?

Experiencing website difficulties?

Or need to contact us for any other reason?