×

Sale ends todayGet 30% off any course (excluding packages)

Ends in --- --- ---

Help running a MK3 Supra Tachometer from a Motec M1 Ecu

EFI Wiring Fundamentals

Forum Posts

Courses

Blog

Tech Articles

Discussion and questions related to the course Motorsport Wiring Fundamentals

= Resolved threads

Author
285 Views

Hey All,

I have been trying over the last months to get my MK3 Supra Tachometer to work with the following setup:

Stock Tachometer gauge Cluster from 1987 Toyota Supra Turbo USDM

2JZGTE VVTI with GTR/Hitachi Coils (No Ignitor/CDI)

TACHO Output from M150 ECU via Peak Hold Injector 8

I can't get the tachometer to read accurately and have only been able to adjust the "scale" in M1 Tune to get accurate reading at a fixed area (ie, 4000 RPMs) with the error in correct engine speed compared to the cluster grows further in either direction.

I've Tried:

Straight from ecu: Little visable function. Wild Sweeps, no form

1K resistor 12v to the tacho output (Accurate down low, very far off at top. 4.5k rpm pegs gauge)

TachoAdapt: This provided some accuracy down low to around 3k, and then error grew.

Dakota Digital SGI-BT100: Currently Wired in. This has a calibration function and with this and the scale in the software I have gotten the best results but still those "best" results have been off by ~200rpm to 4.5k then error grows through 6k rpm+ with over 1.5k rpm error.

Any ideas what I can try? I am wondering if my choice of output from the M1 is incorrect?

Thanks!

Trevor,

Please tell us specifically what engine speed the tach reads when the Motec ECU is reading 2000, 4000, and 6000 RPM via live data in M1 Tune, all with the same ECU scale setting, and let us know what the scale setting is.

Thanks for the help Mike.

Here are the answers to the above.

M1 2000RPM-->Tach 1550-1600RPM Tach 2000RPM--> M1 2380RPM

M1 4000RPM-->Tach 3750RPM Tach 4000RPM--> M1 4150RPM

M1 6000RPM-->Tach 7000RPM Tach 6000RPM--> M1 5400 RPM

At an idle M1 1250RPM-->Tach 900RPM

Current Scale is set to 3.65 hz.

Thanks in advance for any help or advice that you can offer.

Trevor,

Thank you, that's exactly the info I was looking for.

To be honest I've never had the issue you're having. Specifically your data suggests there is no single scale value which will resolve what you're experiencing.

That leads me to believe perhaps pulses are being lost under some or all conditions, or perhaps the output itself isn't quite what's needed electrically. Are you using a pull-up resistor?

What was the original engine configuration (ie, what the tach is probably expecting). 4 cylinder? 6 cylinder? Distributor or coil on plug? If coil on plug, was it running wasted spark?

For Distributor-based, 4-stroke engines, the expected scale would be half the number of cylinders per revolution. For coil on plug you would expect a scale of 2 for sequential, or 1 for wasted spark.

If using the correct scale isn't producing the correct value on the tachometer, then we need to use an oscilloscope to look at the signal and see what's happening. A common problem is you need a pull-up resistor (could be 1k to 10k) to 12V power. If you don't have access to an oscilloscope: (note: I haven't tried this), you might be able to splice into the tach signal and connect it to one of the M1 Udig inputs, then use capture inputs to look at the signal, would work best if capturing cranking or at most idling.

One note, you might need to modify the OEM cluster (these threads might be mkII supras so don't know if this applies). This post has details:

https://www.celicasupra.com/threads/7mgte-swap-tach-modfication.68447/

and here's another one, with a variable pot to allow tuning...

https://www.celicasupra.com/threads/anybody-running-a-7m-tach-mod-gauge-cluster-instead-of-an-msd-adapter.65117/

What is the reported Frequency from Tachometer Output Frequency? You should see the following with your settings.

1250 = 80.2Hz

2000 = 128.33

4000 = 256.66

6000 = 385

If these are the numbers being generated, then the M1 is generating the correct pulses. I do find it interesting that you are requiring a non integer for this value.

Might be a good idea to get the tachometer checked, and cleaned, by a specialist - they usually work or don't work, but there's a small chance its operation and accuracy may be part of your problem?

I don't know the specific operating method for your vehicle, but there are several Toyota owners posting on the MOTEC forums regarding tacho' operation, if you have a look with the search option - https://www.motec.com.au/forum/

Thanks for all the replyies; Mike, Stephen and David.

Current wiring is Output from Peak and Hold Injector 8 from the M150 into the stock chassis/body connector. This feeds through the stock TACHO wire into the cluster.

I no longer have a resistor wired in, but I do have the Dakota Digital SGI wired up and functioning. I will get the Tachometer Output Frequency today at lunch at the requested values to see the variation. At least this should give some direction as the cluster or the ECU generating a signal that isn't useful for this application.

This car originally came with a wasted spark 6 cylinder and we are now running 6 coil on plug "smart" coils with no ignitor.

I do know that this same cluster functioned flawlessly when I was still running the stock ignitor for the 2jzgte and sequential ign. So 6 cylinder to 6 cylinder swap but moved from wasted spark to sequential. Cluster worked when TACHO wire was receiving signal from a stock 2jz ignitor but now doesn't function correctly with the TACHO receiving output from PaH Injector 8.

Hi Trevor,

You didn't happen to get a scope capture of the signal coming out of the stock igniter?

Sorry for the long delay, for those still following...

Here is what the M1 is outputing give or take.

1250 RPM--> 70 Hz

2000 RPM--> 120 Hz

4000 RPM--> 242 Hz

6000 RPM--> 360 Hz

So I'd assume, given the above, that the issue is my Tach. I just couldn't guess why? Especially since when the M1 was outputing directly to the Tacho Wire, the Tach produced the worst results with barely any function. Function improves the more the signal is changed by either the attempted 1K Resistor, the Tachoadapt box, and now the Dakota Digital Tach Interface.

I'm thinking that it must be an issue with how my Tach sees/interprets the signal from the M1. I was hoping that the Dakota Digital Tach Interface could receive and reproduce a better signal. But its as if I'd have to have the ability to change the scale based on Engine RPM. Which isn't possible...

I guess Ill dive into Tach modification. The videos you linked David seem to have some good ideas to try. Thanks!

If anyone can think of any ways to solve this please chime in. Really appreciate the help so far.

Trevor

Hi Trevor,

This is a hack that is used with older tachos that are normally driven by the coil negative output from the coil.

Attached Files

Stephen,

Interesting. I will give this try.

I would assume that the Dakota Digital should be deleted and only the relay wired in?

Thanks!

Just as it is drawn, no other devices or components. If it works, you can pull the contacts out of the relay so that it doesn't sit there clicking constantly.

For Toyota tachs, I bypass the resistor thats on the tach board with a piece of wire. If you follow the copper trace from the cluster connector up to the point it enters the tach board, it's the first resistor. Normally works fine if the cylinder count stays the same.

We usually reply within 12hrs (often sooner)

Need Help?

Need help choosing a course?

Experiencing website difficulties?

Or need to contact us for any other reason?