Sale ends todayGet 30% off any course (excluding packages)

Ends in --- --- ---

Can't get my Nitrous table to work, AEM v1

General Tuning Discussion

Forum Posts



Tech Articles

Discuss all things tuning in this section. News, products, problems and results. 

= Resolved threads


Hey all,

So i'm trying to wire up my nitrous table to be my meth map for my 91 NSX. I have a on/off cutoff switch for my meth kit that's just a toggle for a ground wire and i ran a wire from it to my aem box. I saw on the aem instructions 30-1042 that "Spare Switch Input: Switch #3, Pin C9 gnd=on" was available. And the instructions say "C9 SCS (Service Check Connector) SW3 Switch 3 "ON" when Pin C9 Grounded" so i took my wire and ran it to pin c9, and switched my nitrous table to "NOS Switch in: Switch 3 GND=ON"

However, when i flip my switch to activate the meth kit and the ground to ecu the nitrous table doesn't turn on. (my meth kit does turn on, just not the nitrous table on aem)

What am i doing wrong? Or why isn't the ecu recognizing the ground. Here's a link to the aem v1 nsx ecu instructions: https://bc3b51bfa6153afbccc478ec700858a81fe7f442.googledrive.com/host/0B41SXbgX39SuZkxkb05ydjczczA/NSX/report/ecu/EMS_-_30-1042.pdf

I'd start by simply grounding the input to the AEM to test the nitrous table is becoming active. Forget about your methanol injection for now and simply ground the input with a spare length of wire directly to a chassis ground to test. Once you've got this part sorted you can figure out why it's not activating when you want it to.

I'm not familiar with the AEM V1 but often on a digital input/switch there will be a control for a pullup resistor (if there is then this needs to be turned on), and you may be able to control if the input will be active when the signal is high or low - In this case you would trigger when low.

I've been trying it by simply grounding the input and it's still not becoming active. Where can i find the pullup resistor menu in aem?

I did find someone on the nsx forums saying the 30-1042 had problems where the switched inputs weren't working and had to be returned for a firmware upgrade.

There were some design errors on those old 1042 boards related to these inputs: SW3 (Service Check Connector), SW4 (neutral switch), and SW5 (Clutch switch). We found and fixed these in 2008.

Unfortunately we quit working on that first generation of ECU in January 2015, so if yours doesn't already have the update it can no longer be sent in for service. There are a couple of 3rd party vendors who we have been referring people to and they should be capable of updating your ECU, let me know if you'd like their contact info.

Hope that helps,



Thanks so much for the reply! Stinks you guys stopped service, but super thankful for the confirmation of what my problem is so now i'm no longer second guessing my mechanic skills, haha. Again, thanks so much for the response even though you guys have discontinued service, AEM FTW!


We usually reply within 12hrs (often sooner)

Need Help?

Need help choosing a course?

Experiencing website difficulties?

Or need to contact us for any other reason?