Forum » General Tuning Discussion » Crank sensor problem

Crank sensor problem

General Tuning Discussion

Discuss all things tuning in this section. News, products, problems and results. 


Page 1
Author
102 Views

Hi all. I having some issues with my engine not wanting to start. All was going well trying to cure the hunting idle until the engine abruptly cut out. The fuel pump in the main tank wasn't working, turned out to be the fuse in fuse link tha was loose and not making proper contact.

Cranking problems started after i fixed the the fuel pump. The VR sensor was counting 59 teeth then 117 (60-2 trigger ) so i checked the wires, pulled the sensor cleaned it reinstalled with 50thou gap. Cranked the engine over and it was counting a solid 59 with ignition at 15 degrees however no fuel injection at all. I checked the pinout to the ecu and the wiring diagram and found the shield wire and negative wire were incorrect thus made the change and tried to start the engine however no success SAME as previous result. I messaged the original distributor of the ecu and he confirmed no damaged would result to the ecu if the shield wire and negative wire were mixed around.

I tested the coils individually using the ECU test function and they worked.

Done the same test on the injectors they worked, then checked the plugs to confirm and the were all wet from the test.

Question is, would the mix up in the wiring have an impact on the VR sensor itself.

How can ecu counting the correct number of teeth and firing the coils and not fire the injectors?

This is weired.

I've attached a CSV log file.

Hope someone can help.

Regards

Paxton

Attached Files

when you have rpm in the log and it is reading about the correct rpm that the engine is seeing generally it is not a trigger issue the engine the needs compression spark and fuel

the test function is not testing under cranking conditions so i would be checking again under those conditions

This problem cam become out of the blue, a couple of days prior to this the engine was running and would start without any any problems. I went digging into the forums and came across a very similar situation engine would crank start and die. No injection pulse logs very similar to mine. One thing that was evident was when that he cranked the engine with the fuel pumps off he would get the correct trigger count with spark and injection. As soon as the fuel pumps turned on the engine would cut out. Seemed like too much noise interference with the signal. Unfortunately the post did no conclude with the final out come. I trying a Hall sensor and see if that changes anything.

If turning on the fuel pump changed the noise, I would look for a bad connection in the fuel pump wiring. I would also try a different fuel pump first.

Thanks for the response guys.

So some developments. I Change out the VR sensor and replaced it with a high speed Hall sensor. Configured the ECU and wiring to the ECU to suit. Tried starting the engine it fired up and died after 2 seconds. Still no injector pulse. I checked voltage to the injectors which low approx 3v just with ignition turned on. Checked the injector resistance and all were 08.5 mil Ohms. I also changed the injector and coil relays on the relay board, not that they were bad.

Now here's where it becomes strange. I noticed the MAP selector switch wasn't working thus i traced the wiring and found the ground wire wasn't connected, somehow came loose.

Connected the wire and switched to MAP1 and i noticed that injector pulse width on the monitor was fluctuating with ignition turned on. very little probably due to power being supplied.

I change the fuel parameters to suit the injector flow characteristics and adjusted the timing as per MAP0.

Cranked the engine over and it fired up. I let it run for 5 minutes with hunting idle. The trigger count was a solid 59 no fluctuations.(60-2 trigger wheel )

The question thus is, why does the MAP0 not activate the injectors. Clearly there's no hardware issue since it fired up on MAP1.

Can the firmware be corrupted or has the VR terminals on the board been damaged since i had the negative wire and the shield wired to the pins mixed up.