×

Sale ends todayGet 30% off any course (excluding packages)

Ends in --- --- ---

Dyno X Hub Dyno Steady State Issues

General Tuning Discussion

Forum Posts

Courses

Blog

Tech Articles

Discuss all things tuning in this section. News, products, problems and results. 

= Resolved threads

Author
206 Views

I'm having an interesting issue currently. I have a car on my Dyno X hub dyno right now that won't seem to hold an RPM in steady state. With light throttle increase, the rpms continue to climb. I'm thinking it MAY have to do with the diff opening up and not producing equal load on both axles, though this is a total guess and am looking for some insight from any other hub dyno owners who may have run into this issue in the past.

The interesting thing about the dyno X pods, is that there is a speed controller on only the "primary" pod, so viewing speed on both pods to confirm this is a diff issue is a no go.

There are no rules that say you can't add additional speed sensors to either the car or the dyno and connect them to something that can monitor / log them. If you want to know the answer -- add a sensor and log the data.

I have added oil temp sensors to each of my Dynapack pods. Knowing the oil temp helps me regulate the water to get consistent results.

Does the Dynocom software have a provision that allows you to tune the PID control for steady state? Perhaps a smaller dead-zone, or increased I component would hold the RPM steady for light changes.

I never thought about adding speed sensors to the dyno to monitor speeds externally, what a great idea! I'm definitely going to look into doing that ASAP.

Dynocom does use PID to control steady state functionality though I'm not sure if I'm able to change the PID parameters to fine-tune. That will be the first thing I'll check when I'm back at the shop.

In your experience, how have you dealt with open and LSD style diffs on a hub dyno? is it a matter of monitoring wheel speeds and adjusting individual suspension heights to account for load/drag side-to-side to keep them spinning evenly?

I've never had an issue I attributed to the diff. The two hub speeds seem to stay very close.

Is it possible to feed the dyno the Engine Speed from another source (CAN / OBD2 / coil pickup)?

How far off does the RPM go (+50, +200, more?), does it eventually come back? When that occurs what happens when you decrease the throttle?

Another thought -- could the torque be falling as you add throttle / RPM (so a tune issue)?

Have you tried different gears? Some cars with lightweight drivetrains (and very little torque), work much better in lower gear (higher numerical ratio) because it makes more torque and the dyno can control that more easily.

I was able to confirm that both pods are indeed spinning at the same rpm via external speed sensors. This rules out any diff related issues I was fearing. I did try to perform the run in a lower gear, but ran into the same issue.

The RPM continues to climb the more throttle I give it, it can go well over 1000rpm over target. I paid close attention to the PID control gauge and found the issue: the dyno is not commanding any PID at all during the run. I perform the exact same run with MPH as the target instead of RPM and the dyno holds steady at the commanded MPH. My guess at this point is that this MUST be a software related issue.

I've also tried changing my rpm pickup to "calculated gear ratio" and "coil pickup" and confirmed that the dyno is reading the RPMs correctly and cleanly.

Does sound like you've found a bug.

Just to confirm, you are using a manual transmission, not an automatic (torque converter), which could have a variable gear ratio if not locked up (light throttle).

Yes, I am using a manual transmission.

If I find there is a software fix for this, I'll report back with the fix for any one that may run across this thread with the same problem in the future.

I appreciate all the help!