×

Sale ends todayGet 30% off any course (excluding packages)

Ends in --- --- ---

Fuel Pressure dropping off above 3k rpm / any boost RB26

General Tuning Discussion

Forum Posts

Courses

Blog

Tech Articles

Discuss all things tuning in this section. News, products, problems and results. 

= Resolved threads

Author
374 Views

Hi all, I'm having an issue under any kind of load / boost above around 3000RPM on my R32 GTR. Basically, the fuel pressure is dropping just at the time it should be rising and is causing the car to go very lean which is obviously not good. I've already replaced the fuel pump for a Walbro 450 lph and new sock, fuel filter in the engine bay and FPR for a new Tomei one that takes its reference from the balance chamber, the MAP sensor takes its reference from the other side of this chamber. New Bosch 1000cc injectors. I've also run a return flow test and this also checks out fine. I've removed the in-tank damper.

I have the fuel pump on a direct feed (12 AWG) to the battery + and a good earth right near it to the chassis. I tested it today at 5 bar and the amp draw is around 10A. The alternator appears to be able to supply enough amps as if I turn everything on at idle it supplies around 26A. I've also tested the the voltage with everything on at idle and it only drops from 14v to 13.5v. I then retested this holding the revs at 4-5k rpm with the same results.

I'm a little lost on what to check for next. Thanks for any help!

https://drive.google.com/file/d/19Unx4BHm1xxJjQhVv_87udramQQiOANx/view?usp=sharing

""

Well, something is drawing a lot of current or your alternator is disabled at WOT based on the drop in battery voltage which seems to match your fuel pressure drops.

Are you sure you're not running out of fuel.

Is this new problem on an existing setup, or a new installation?

How are your fuel lines sized?

I can't figure out what could be using a lot of current apart from the fuel pump. I have every other accessory off while testing now. Do you mean disabled as in faulty?

Don't appear to be as the return fuel flow test was good. 8mm standard lines so fine for up to 600bhp ish. I'll be at 450 max when I'm done. Nowhere near that at the moment and while experiencing these issues.

I believe it's always been there since I've had it but probably just tuned out while in Japan on the Power FC looking at the old map. I have no history from Japan and only had the car for a few months. I swapped to a Link a couple of months ago which I'm tuning at the moment so spotted this issue.

It's possible with some ECUs that do alternator control, to disable the alternator at full-throttle to remove the load and provide extra power. Unless you've wired it to do that it's unlikely (although we used to do that in the 80's with Porsche 911 engines using a switch on the field wire to the alternator).

Ok, yeah definitely not doing that.

It's interesting that your voltage drops relative to the throttle position. I worked on a car that had low-impedance (ie. peak and hold) injectors, but the ECU didn't have peak and hold injector drivers. When the driver put his foot down leaving the pit lane the battery voltage would plummet as the injectors were all opening longer and the current draw (with a V8 it was huge). We thought it was a wiring / alternator issue, but it was incompatibility with the injectors. Problem was eventually solved with an external injector driver box.

You have 1000cc Bosch injectors - I assume those are high impedance. I don't believe the Link ECU support peak-and-hold injectors.

Don't think it's related to TPS position necessarily. It just tapers off during acceleration.

The injectors are compatible, lots use these with the Link.

I'm going to go over the wiring again today but if all good, I'm scratching my head as to what could be the issue.

I would suggest you first look at the voltage ACROSS the pump - it's +ve and -ve terminals - and also between the -ve and the chassis/frame at a good ground point.

Even without the ECU interfering, however that might be, there can be a significant voltage drop in the circuit to, and from, the pump and, as the power is approximately related to the SQUARE of the voltage, so a nominal 13.5V is actually 10V the pump is only operating at around 55% of what it should be doing.

I'd set up a test rig, with an oversized gauge wire (I like a couple of gauges up on "nominal" values for power cuircuits) for a direct ground and switched and fused manual switched feed directly from the battery, to make sure the pump is working to capacity and take it out of the trouble shooting process.

If the problem remains, you need to look elsewhere, but if the problem goes away you know you need to go into things further.

Depending on your specific application, I don't know the details, I'd be inclined to replace the wiring to the pump, or bypass it, with the ECU actually switching a separate, fused relay on a direct, battery fed line.

I did get a chance to test some more with the following results.

@ 5 Bar Fuel Pressure:

13.8v At The Battery

13.4v Link

13.2v Relay Feed In

12.92v Relay Feed Out

12.85v Fuel Pump Connector

If I bypass the relay and ECU I get the same on road results and the following:

12.85v Fuel Pump Connector

So it doesn't look like relay or ECU being the issue.

With the car off the battery reads 12.75v and the exact same voltage when testing in the boot for the feed to the pump.

So it seems like too much of a voltage drop between the battery and pump only when it's running fast / higher amps which would coincide with my results.

I also had a chance to use the Picscope to test the fuel pump connector while driving. The log is below. Appears to be between 13.2v ish and 12.8v ish when being pushed. I'm new to Picoscope and the software though and unfortunately the amp clamp can't be trusted as it drifts almost instantly after being connected. I've ordered a new one this morning. Again, I feel like this should be more like in the 13.6v range accounting for voltage drop, amps being pulled and length of cable according to online voltage drop calculators.

As mentioned, I already have a direct feed from the battery +ve, this is from the battery in the front and the pump is in the boot and a decent, tested earth for it around 12 inches away from the connector so still a little confusing. I guess the next step is what you are recommending and to replace the +ve feed with a new higher gauge cable in case the Japanese run AWG12 is an issue.

https://drive.google.com/file/d/1YiQzv9xZxyC0AjFqtr5xk37Av6JrmgKZ/view

Is it a Link plug-in or a wire in?

Maybe not related, but I've seen some wire in installations that were using the +12v Ignition wire (Black/Red from pin 45) and that was messing the voltage at the ECU. You either need a relay to have a more accurate voltage to the ECU, or use a DI for the Ignition Switch and use the ECU Hold method.

If you have a plug in ECU, this should not be necessary.

Here's a screenshot from an install from ECUMaster that shows the issue. You can see the voltage randomly dropping, this will mess with injector deadtime values. Your log show some of these voltage drops.

Again, probably not related to the fuel pressure issue!

Attached Files

Thanks for the replies. It's a plug-in.

Ran a new cable today. AWG 4 with the appropriate fuse holder and new relay for good measure.

Voltage drop and voltage to the pump are much better. 3 and 5 bar are 0.3v and 0.4v drop respectively but still the same on-road results.

I'm yet to run the Picoscope while driving as I ran out of time today but the return fuel test went fine and the alternator appears to be able to supply the amps the car and pump needs.

Could it still be the alternator somehow despite my tests? Other than that I'm really not sure what else there is I can try...

What if you lower the base fuel pressure, so that in boost the pump doesn't have to provide as much pressure. Since you mentioned fitting 1000cc injectors, what is your maximum injector duty cycle? Do you have enough margin to try that?

I've seen this happen with a battery that was on its way out, it still delivered ~13V. but couldn't keep up with the current supply so devices that had a larger current draw would not be able to run at their optimum.

David, I did already perform a return fuel test which came out fine at 5 bar so not sure if trying that is going to tell me anything else?

BlackRex, Battery is new.

Stewart

Just an observation, your EGT is awefully high, scratching 1000 degrees C.

Yeah, it’s on the priority list. The AFR’s being higher sometimes because of this issue doesn’t help! I need to tune it properly but can’t at the moment until this issue is resolved.

Just for my own sanity I moved the FPR boost reference to the rear of the balance tube to use the same as the ECU and wrapped PTFE around the adjustment screw. This made no change.

Then I started looking at any high current items I could scope or disable so I disabled the 4WD and ABS as well as pulling most of the relays and fuses that weren't necessary while testing. Still no change.

I scoped the pump again and this looks like it's getting the current and voltage it needs and does not dip nearly as much as the ECU voltage so still a mystery why I have the differential fuel pressure....

The ECU is still seeing as low as 12.75v ish when the issue occurs but the fuel pump is only seeing lows of 13.3v.

Amps increase slightly with increased fuel pressure as you’d expect.

The issue is not as pronounced in slower to build RPMs and boost runs.

[url=https://drive.google.com/file/d/19L-dyvswf1itpFUykT4HxyCsFmeSISTH/view?usp=sharing]https://drive.google.com/file/d/19L-dyvswf1itpFUykT4HxyCsFmeSISTH/view?usp=sharing

[url=https://drive.google.com/file/d/1z3WO-BoKqyAwUJcRv0iRipcx-q0BOcGn/view?usp=sharing]https://drive.google.com/file/d/1z3WO-BoKqyAwUJcRv0iRipcx-q0BOcGn/view?usp=sharing

Still fighting this!

Just got back from a few days away and just tested again without ABS + ATTESA ECU connected just in case they were drawing a high current. No change :(

Also tried a run without the fuel cap in case that was at fault. Also didn't make any difference.

ECU is still seeing voltage dropping from 13.4ish down to 12.8ish on these high rpm runs. Fuel pump isn't.

What can I look for that would be causing this as surely the drop of voltage to the ECU (and probably other electrical items?) is not right?

I've checked the earth and positive ECU pins and all seem to check out fine in regards to voltage drop and resistance at idle.

I replaced the new 450lph Walbro fuel pump over the weekend for a Walbro 255lph as Mark mentioned it was worth trying and just in case the 450lph was either faulty from new or too strong for my setup/FPR. This had made no difference.

I also bought a Mytivac to make sure I had bang-on control as using the air compressor was a little janky. I re-ran the return fuel test with new the 255lph pump based on the specs given by Walbro at 3 and 5 bar and they come out bang on specification so I'm pretty sure my pump, wiring, fuel lines, FPR and filters are ok (unless I'm missing something?) along with the fact the 5D fuel table works pretty well to add extra fuel when needed so the fuel appears to be there it's just not matching 1:1 with boost from the usual way. I don't want to end up relying on this 5D table as a workaround.

Been out for another run. 1st is with boost control turned on, 2nd without. I had a theory that above WG boost could be an issue but doesn't seem to matter.

Any ideas anyone?

""

[url=https://drive.google.com/file/d/1pOu0tNKYI0yP2OEIRbYxI2MKNqbw6Hrf/view?usp=sharing]https://drive.google.com/file/d/1pOu0tNKYI0yP2OEIRbYxI2MKNqbw6Hrf/view?usp=sharing

[url=https://drive.google.com/file/d/1Uz9X5BJ8wfFlhYyw8ODo-UF2QI3U1qsE/view?usp=sharing]https://drive.google.com/file/d/1Uz9X5BJ8wfFlhYyw8ODo-UF2QI3U1qsE/view?usp=sharing

Stewart,

Another observation. Is the ripple in the RPM signal new? There's a lot of swing in the engine speed in all the operating range, are you using OEM CAS?

Have you tried to connect a standalone fuel pressure monitor, that isn't connected to the vehicle / ECU supply? Easier to do on a dyno if you have access to one, but it looks like there's a lot of issue with some signal going to the ECU, I would try to confirm if it's actually a problem.

Do you have a copy of your tune file somewhere?

Thanks for the reply, Frank. The laptop I use for logging could do with an upgrade so seems to log at low hz. Log from the ECU is a lot smoother. It's the OEM CAS with an AEM wheel.

Definitely does seem to be an issue as previous to logging the fuel pressure I didn't realise what was going on and my fuel map was really odd looking towards the end of map to offset the issue.

My fuel pressure sensor is powered separately to the ECU and goes to a GReddy gauge which shows the same issue as the ECU logs. The only reason my AFR's stay even remotely close to target is a 5D table to add more fuel based on differential fuel pressure.

Tune here:

https://drive.google.com/file/d/1LtDXKp6pjMTKdcl91SSYTwB2JornH3WU/view?usp=sharing

""

I missed the part about 5D fuel table but now it makes sense that it compensate for the fuel pressure dropping.

Here's a couple of ideas and my thought about them.

-Too small fuel pump (Shouldn't be an issue on your setup)

-Worn out fuel pump (You replaced it so it should be good)

-Too small fuel lines (Shouldn't be an issue on your setup)

-Fuel lines clogged

-Wiring too small for the current draw of the fuel pump

-Issue with 12v+ feed of the pump (not enough voltage)

-Fuel pump ground not adequate (GTRs have a fuel pump module on the ground wire, which should be the white wire on the 2 pins connector IIRC. You should bypass the fuel pump module by grounding the white wire on the chassis (fuel pump side obviously))

-Terminals in connectors not seated properly / corroded

-Fuel leaking somewhere (could be the hose between the pump and the access cover in the fuel tank)

-Fuel filter/strainer clogged

-Bad FPR

Just to make sure, did you do a test by using compressed air to add boost (let's say 10psi) in the FPR vacuum line and check if the fuel pressure was matching the base pressure + the added "boost", with the engine not running and the pump running?

Actually ECU logging is still quite erratic RPM. Jumps about a fair bit!

https://drive.google.com/file/d/1ovgrsL_LaciLr5FQQgwEnMY6tgpX0kAq/view?usp=drive_link

Thanks for all the suggestions. Really handy for anyone else viewing the thread to know exactly what I've tried so far.

-Too small fuel pump (Shouldn't be an issue on your setup) - Tried brand new Walbro 450lph and 255lph with no difference.

-Worn out fuel pump (You replaced it so it should be good) - See above.

-Too small fuel lines (Shouldn't be an issue on your setup) - Hopefully not, only making around 350ish at the moment.

-Fuel lines clogged - Shouldn't be as the return fuel flow test comes back as perfect at 3 and 5 bar.

-Wiring too small for the current draw of the fuel pump - Since the issues have run a 4AWG from the battery

-Issue with 12v+ feed of the pump (not enough voltage) - As above + Picoscope suggests this is all ok while performing a run.

-Fuel pump ground not adequate (GTRs have a fuel pump module on the ground wire, which should be the white wire on the 2 pins connector IIRC. You should bypass the fuel pump module by grounding the white wire on the chassis (fuel pump side obviously)) - Already bypassed and have a direct positive feed from the battery and negative to chassis 12 inches from pump + changed the relay and cables in and out. ECU now only controls on or off of the pump.

-Terminals in connectors not seated properly / corroded - All checked / changed when changing relay and pump.

-Fuel leaking somewhere (could be the hose between the pump and the access cover in the fuel tank) - Changed the pipe for this when fitting the second fuel pump.

-Fuel filter/strainer clogged - Changed engine bay one for new + filter sock with new pump fitting.

-Bad FPR - Changed for genuine Tomei vs unknown brand one I had before.

Just to make sure, did you do a test by using compressed air to add boost (let's say 10psi) in the FPR vacuum line and check if the fuel pressure was matching the base pressure + the added "boost", with the engine not running and the pump running? - Yes, exactly that. Increase pressure via Mitivac to FPR = exactly the same rise in pressure to fuel system. Have actually done this test with the engine running and off.

Essentially everything looks perfect and I've tried everything I can think of!

I can only find the fault when on the test drives. It seems like either the FPR is not seeing the right reference (which would be odd as I've tried this on the same line as the ECU map sensor and separately) or the additional strain of feeding the injectors just pushes it over the edge to stop supplying enough fuel but then saying that it can supply enough fuel as the 5D table takes care of it...

I notice your configuration for the Fuel Pump Control is setup for a 3-speed relay. The switch to high occurs at 2500 RPM / 22% IDC -- is this really how the car is wired? If not, then what are Aux1 and Aux2 wired to? Because they are switching with RPM and Injector Duty Cycle, and could be changing the electrical load / voltage.

For your noisy RPM signal, you might want to try increasing Triggers->Trigger Setup->RPM Filtering to see if that helps. I suspect that the low tooth count could be part of the reason for the fairly regular noise.

I've mentioned before that I thought your issue seemed related to full throttle, and I notice that the AC Clutch control will attempt to disable the AC clutch at 90%+ throttle -- is that wired correctly? DI4 for the AC Switch, and Aux3 for the Clutch control.

Are you using ECU logging? You should be able to log many more channels than what the posted log has. If it's a configuration problem logging all the channels could really help us see what is related to your issue.

You don't need to reply -- just ideas for you to consider / investigate.

Thanks David. I’ll just answer the one q now about the fuel pump control. That must be a slightly older version of the config as it’s just set to standard now. Either way it made no difference as I bypassed that function / FPCM many months ago. I also tried bypassing the ECU control and the relay completely as a test but again made no difference to the symptoms.

Your other suggestion are welcome as they are something new for me to investigate. I’ll take a look at those and reply back with my findings.

I've increased the filtering to 4 which seems to improved things, I think.

I've left the AC Clutch Control as standard as is the wiring.

I have setup ECU logging but at 500hz as someone else wanted to see these logs. Have linked that and a PC log with some 50% TPS runs with the same symptoms.

https://drive.google.com/file/d/1EuAuvV9fXg8cF0Ouxeao5UxsMVLh5UqN/view?usp=drive_link

https://drive.google.com/file/d/1slfYieXcmuorTAMl-Mu1tb0LWGct3Mfq/view?usp=drive_link

""

We usually reply within 12hrs (often sooner)

Need Help?

Need help choosing a course?

Experiencing website difficulties?

Or need to contact us for any other reason?