Sale ends todayGet 30% off any course (excluding packages)

Ends in --- --- ---

Haltech PS1000 coms issue

General Tuning Discussion

Forum Posts



Tech Articles

Discuss all things tuning in this section. News, products, problems and results. 

= Resolved threads


I am having an issue with my haltech ECU loosing connection with the laptop when making changes (as indicated by the * in the lower left corner)

pretty much runs perfect, connect a laptop make large changes, the * stays on. about 5 seconds later the engine dies and the laptop looses connection with the ecu and then the ecu cycles on and off and n and out of connection. to fix you turn the ecu off and on, then reconnect with the laptop.

now the ecu was sent back to haltech and bench tested with no issues.

tried 3 usb cords and two different laptop (tuners laptop which tunes 100's cars) and the issue still occurs.

I wired the ecu my self with soldered connections (I now know better) so the next issues is the wiring so what do you guys suggest to help diagnose?

first off I want to see if I can fault with the engine not running, if I cant then this to me suggests an interference issue.

if it does fault with the above test I was going to remove the secondary (smaller connector) and repeat, this would then rule out air and water temp sensors as well as the switches for launch and datalog.

looking for some trouble shooting tips please guys.

engine is a gen 3 3sgte from a ST205 celica running 1zz COP and other wise stock, can wideband and racepak dash.. if it helps

Ok so tried making it lock up with the car off and it can be done.

So now I'm not sure if it could be interfearance.

If it was witing wouldn't it freeze all the time?

Are you running your laptop off the battery, or are you using an automotive charger (cigarette lighter e.g.)?

I've found out, that with no charging device connected, some ECUs have a certainly more stable COM connection. In my case, the reason for that was the ground source of the cigarette lighter.

Yes my laptop has been run off its battery only at this point.

just trying to methodically work through this,

I disconnected the smaller connector, can still make it freeze.

turned off the DPO for thermo fan as it runs inverted. no change.

attached is a photo of the * I refer to, I believe it indicates data transfer.

Attached Files

no one else has any ideas to try?

rather annoying since im paying my tuner by the hour and this slows him down considerably

he seems to think it must be wiring since haltech found nothing. but where do i start with wiring?


hey just an update on this,

ecu went back to haltech 3 times once was bench tested and new usb to try, second time the usb coms port was replaced, third time ecu was replaced.

any now everything works as it should, thanks to haltech for solving the issue even though it was out of warrant period.

I'm glad to hear you got to the bottom of a frustrating problem. Great work by Haltech too!

We usually reply within 12hrs (often sooner)

Need Help?

Need help choosing a course?

Experiencing website difficulties?

Or need to contact us for any other reason?