×

Sale ends todayGet 30% off any course (excluding packages)

Ends in --- --- ---

Lambda and Fuel pressure issue ECUMASTER Black

General Tuning Discussion

Forum Posts

Courses

Blog

Tech Articles

Discuss all things tuning in this section. News, products, problems and results. 

= Resolved threads

Author
785 Views

Hello,

I am having some problems with what I think is a fuel setup issue but before I start to tear off the complete fuel system ones again I would like to get a second opinion.

Attached are the Map and the last log I did after some modification. The map is not complete, I just did some basic VE table and Ignition table to be able to run the car and try to diagnose the problem.

Lambada is all over the place even if stays steady in one position, would be great if someone of you could bring me some light here so I can root the problem and be able to finally finish the car.

Thank you all in advance for your help.

Javi

Attached Files

Looks like your battery voltage is very erratic. I would try to solve this issue before checking your fuel setup!

Also, your Accel enrichment seems a bit low at low TPS rate.

Hope it helps,

Frank

Hi Frank,

First of all, thanks for your answer.

I am aware of the battery issue but if you really pay attention battery voltage stays pretty solid on the areas were the lambda bounce that much.

Also, you think this fuel pressure behaviour? my main concern was fuel flow due to the changes on Fuel pressure.

Acc. enrichment is not yet mapped so I am not so worry ATM because I don´t drive the car.

Thanks ones again for your time.

Javier.

We usually reply within 12hrs (often sooner)

Need Help?

Need help choosing a course?

Experiencing website difficulties?

Or need to contact us for any other reason?