Forum » General Tuning Discussion » link can lambda stopped working help.

link can lambda stopped working help.

General Tuning Discussion

Discuss all things tuning in this section. News, products, problems and results. 


Page 1
Author
89 Views

hi. so my can lambda running on my monsoon ecu was working fine. was running a log and it just stopped reading! so run a log to record it and i am getting error 16 heated too long. also error 33 open circuit APE-IPE and 34 open circuit RE-IPE and its cycling between these 3 faults. can anbody shed any light on what is going on here!! i have checked the sensor and the wiring visually and everything looks good. no loose wires pins etc any help would be much appreciated! thanks. luke.

Attached Files

If it's reporting open circuit, you should get out your ohm-meter and check the continuity of the wiring harness, as well as the heater pins on the sensor. Visual inspection is a first pass -- if you don't find anything you have to dig deeper.

Did you try another sensor?

I don’t have another sensor to try unfortunately or I would try that 1st. I will have my meter tomorrow so will check the wiring like that. I just wanted to ask if anyone else had this same issue 1st. As the only reason I’m confused is the sensor is warming up “according to the data” and then it’s switching faults. However that doesn’t mean it’s not a broken wire or sensor etc.

It's most likely going to be a sensor unfortunately although i've found the Link CAN-Lambda to be pretty robust. Since they consider engine speed as part of their heater control strategy they should offer better sensor life than many wideband controllers.

Hi Andre. Thanks for the response. In a way I hope it is the sensor as that’s the easiest fix. However that said concerned if it is as the car has only done 50 miles of safe driving! Reluctant to spend £80 on a new Bosch wideband Sensor for it not to be that. But then I guess I have a spare! What is the best way to test a wideband sensor ? Thanks. Luke.

Here is a thread with wiring checks for various OEM O2 sensors.

https://www.scannerdanner.com/forum/diagnostic-tools-and-techniques/327-air-fuel-ratio-sensor-testing-thread.html

Note Error 16 is usually related to a bad power supply, and that will cause 33&34 when it shuts down. Either it is not capable of supplying enough current/voltage or I have seen problems also when connected to a very noisy power supply (such as say an ignition coil or VVT solenoid supply). Try running two new temporary power wires direct to the battery (just alligator clip jumper leads or something will do), if the errors then go away you know you need to look closer at the power supply.

hi adam. i tried what you said. i cut the live feed to the can lambda and run a wire direct from the battery. and you was correct it now works again perfectlty. strange at why it ust to work anyway. question is can i run it with a direct live feed ? or do i need to run it via a relay ? thanks for the help!

Hi Adam can I wire it direct ? Or does it have to go via a relay ? Thanks.

You should use a relay - a separate one.

The CANLambda requires ~8amps so you should have your power supply wired accordingly, usually through a relay with appropriate sized power and earths.