Sale ends todayGet 30% off any course (excluding packages)

Ends in --- --- ---

Link G4 / ViPEC iSeries new VE Fuel Model - Fuel Cell Numbers maxing out

General Tuning Discussion

Forum Posts



Tech Articles

Discuss all things tuning in this section. News, products, problems and results. 

= Resolved threads


Happy Holidays to all!!

We are tuning a Turbocharged 4 Cyl Drag car on methanol using Vipec i88, and have chosen to use the VE Fuel model equation. Seeing Links G4+ firmware/software are much more up to date than Vipec's, both were loaded and configured. Everything works beautifully except when the engine starts to go into boost.

In the Vac areas the Fuel Cell numbers are low (30's), however as the car starts to go into boost, in order not to run lean, the numbers had to be increased as high as 130 at 4psi & 4000rpm. At 7500 rpm @ 20psi, the numbers are as high as 150. There's no way to add additional fuel. After 8000 rpm the A/f goes lean with all cells fully maxed - Injector Duty Cycle at 62%

I sent the map and log file to Link to see if there's something I'm overlooking but nothing is jumping out at them. They told me to try adjusting the Peak and Hold Amperage for the injectors to see if it makes a difference. We are planning to go back to the dyno next week, and make the suggested changes.

For fuelling we have (8) 2433cc Siemens Deka injectors. See Data below 


The fuel pump & Regulator are both belt driven design units and are made by Aeromotive. The pump is capable of 1800HP on methanol, & is a mechanical cam driven unit. So Fuel supply certainly is not the problem.

I sent the map and log file to Link to see if there's something I'm overlooking but nothing is jumping out at them. They told me to try adjusting the Peak and Hold Amperage settings for the injectors to see if it makes a difference. We are planning to go back to the dyno next week, and make the suggested changes. In case that's not the problem, anything else anyone can think of?

Thank you


Is the fuel pressure regulator referenced to manifold pressure so the relative (differential) fuel pressure stays constant with boost?

Are you running it with open loop lambda table on or off?

What happens if you try it in traditional?

Post up the map if you like and I can have a look.

Thank you for your replies. In answer to your questions:

The fuel pressure is referenced and raises 1 psi per pound of boost.

The closed loop Lambda mode is Off

Im sure this wont be the right way or the only way . But what i found if you input your injector size as only half the actual size you can reduce the the numbers in the fuel map by 50% as a whole . Also found that if you input your fuel pressure lower than you are actually running this will also allow you to do the a similar thing . This is just to let you know what i have done and i have no great expertise in tuning - Ken .

Hi Ryan,

Are you using fuel pressure as an input to the ECU? Or are you just manually entering your base fuel pressure? Assuming you're not using fuel pressure as an input to the ECU, have you actually verified that the fuel pressure is stable at high boost/high rpm, and not dropping off?

I'll assume that you have your fuel characteristics correctly adjusted to suit methanol fuel?

Please post your map and I'll take a look when I can. A log would also be helpful.

Hi Andre, I am not using fuel pressure as an input. I entered the base fuel pressure. I assume the VE model caters for the 1 to 1 rise in fuel pressure?

Yes the fuel pressure is rock steady and rises in proportion to boost. Siemens's deka does not offer very much data for their injectors. I entered the fuel injector data supplied. The batt offset data seems accurate as it's a 16v system with no alternator and the Lambda values are consistent as the voltage drops off. There aren't any short pulse width data.

The tech at Link did ask if the cc ratings of the injectors entered were for methanol. I was not aware the ratings differ across fuels. I just entered the listed 2433 cc. The other VE model settings entered are for methanol.

I really appreciate your assistance on the matter. I am currently on the beach side with family and friends for New Years and don't have access to the map / log file. I will post a copy as I get back.

It's almost 2017 on your side of the world, so Happy New year to all.

On any maximum effort engine I'd recommend running a fuel pressure sensor into the ECU, however provided the fuel pressure is doing what it should, that's really a separate issue. If you have a fuel pressure sensor connected to the ECU then the ECU will use the actual fuel pressure in the fuel model, however if you don't and you enter the base fuel pressure then the ECU will assume a 1:1 ratio for a return-style fuel system.

The injector flow does depend on the viscosity of the fuel and this varies between pump gas, E85 and methanol. The sort of differences however are usually small so this alone doesn't explain your issue. I'll take a look at your files once you have the chance to upload them.

Happy new year.

Thank you Andre!!. Suggestion noted. There is an existing FP sensor being logged by the Racepak logger but I will take your advice and log to the ecu. Please see attached map & log file

Attached Files

Quick look at your file and first thing I see are massive air temps 140c! One issue with this is I see you're also still running an IAT Fuel trim table along with having your charge temp table set to 0 (IAT Biased) this will be removing around 10% fuel (global).

As Andre mentioned fit a Fuel pressure sensor and check that you aren't just having a fuel supply issue

Hi Chris, thank you for your feedback. I noticed the Air temp being very high, particularly at higher rpms. (BTW the temperature is in Fahrenheit not Celsius). I have to figure out why and address the issue. I may be wrong but I don't think that's the cause as the numbers start to quadruple immediately as the engine transitions from vacuum to boost which happens way before the Air temps begin to rise.

Although the fuel pressure is not inputted into the ecu, it is in fact logged through the Racepak data logger, and is rock solid at where its supposed to be. But I will connect a FP sensor input to the ecu as Andre suggested.

I altered the Charge temp table while on the dyno to see if it made a difference but nothing noticeable. Any particular settings you suggest?

My data says its definitely in Celsius not Fahrenheit, Attached are the screen shots of imperial vs metric. As mentioned the IAT is 138C (277F) and circled on the right. Although as I mentioned earlier I don't think this is the issue although won't be helping. Still very high for not a huge amount of boost.

Changing your charge temp table numbers won't have a massive impact on your AFR on boost, maybe 3-5%. Although the point with having the charge temp table is to disable the normal IAT fuel trim table and only use it for smaller corrections if needed. The charge temp table SHOULD do all calculations for IAT trims as it works in the background using the ideal gas law.

Other thing I noticed is you're running at 56c water temp, at this temp you're still getting an influence from your warm up enrichment. If you intend to run the motor at this water temp I would suggest setting these areas to 0 in the warm up table.

I can't see much else that would cause a huge issue, They look pretty sensible but have you tried changing peak and hold numbers?

Secondary injectors are definitely coming in? I know the ECU says they are but can you see them turn on in the Lambda trace?

Attached Files

Temp config noted - Thank you.

I will disable the IAT fuel trim as suggested but I'm aware this is not the cause of the problem.

In regards to the warm up enrichment still influencing fueling, I intentionally changed it on the dyno to monitor the effect on Lambda, however there was very little change. I actually forgot to change it back.

The secondaries are in deed coming in as I purposely adjusted them to stage in earlier than needed, to gauge the effect on A/F which was definitive. I also ran the engine solely on the secondaries just to verify functionality.

Link suggested to change the P&H settings to 4Amp (Peak), 1 Amp (Hold). However, we have not been back to the dyno to test as yet as Im trying to determine all possible causes in an effort to minimize wasting time and money in the event it does not solve the problem. However I'm really hoping this is the cause.

What is baffling me is the numbers almost quadruple on transition from vacuum to boost. Its almost as though its a NA Fuel based Model and the ecu sees anything above atmospheric as an issue.

Hey Andre / Chris, I just finished installing and configuring the FP sensor as suggested. In the help file, under the 'FP Sensor' description it says: "Only this mode supports a rising rate regulator."

I don't understand why 'Map Referenced' won't support the same but I'm hoping this is the cause of the problem on transition from vacuum to above atmospheric presssure. I assume the Ecu is interpreting it as a problem and disregards the numbers in the boost related fuel cells. We are aiming to go to the dyno this week. I will keep you'll posted.

Thanks again

Hey Andre / Chris, I just wanted to update you'll. We went to the dyno yesterday with FP sensor installed, along with all of the other suggestions made by Link's technical support team. Unfortunately there was absolutely no change.

I switched from "Modelled" to "Traditional, retuned, and all is well. I'm quite baffled. I was looking forward to using the Modelled equation.

That's quite unusual Ryan and I'd like to get to the bottom of it. I'm going to run this past my contact at Link and see if they can come up with any ideas.

Might be something stupid and not the issue, but I noticed you have MAP limit turned on and the MAP limit table is set to 20 PSI with a control limit of 250 kPa (about 36 psi).

Also, if I am looking at and understanding the tune file and the log file, it looks like you have 4 wideband sensors fitted (one for each exhaust manifold runner, I assume) and a 5th sensor in the downpipe. To me, it looks like every cylinder is running super rich except for cylinder #4 (according to the labels on the AN Volt inputs). And the downpipe sensor also looks to be reading super rich, according to the log file. Did you check AFR with a wideband sensor from the dyno or some other source that showed a lean condition that the installed sensors are not reading (except cylinder #4)?

To me, it looks like the wideband sensor in cylinder #4 is either not wired correctly or the sensor is toast because the reading of 1.280 lambda is above the Output Value B on Cal 5. Do you get a fault code for this sensor (AN Volt 8)? And if the sensor is fine, then perhaps the injector on cylinder #4 is not wired correctly or is toast...

I agree about it probably being something silly that we are overlooking. I would like to find it though : )

I actually turned the MAP Limit table Off but there was no change.

You are correct about the 5 widebands. We are running an AEM 4 Channel UEGO (1 per cyl) as well as 1 in the D/pipe. The channel for Cyl 4 is not working, hence the reason for the constant lean condition.

The reason for it being super rich is because we are using methanol and that's where the engine makes most power. The critical point to note is the numbers start to go crazy high as soon as it transitions from vacuum to boost (especially at higher RPM's). When I converted from Modeled to traditional, I used the exact same map and it worked fine after some tuning.

What lambda values are you seeing that make you think the car is running lean? On the log you posted, all the AN Volt inputs seem to be reading at about 0.600 lambda until you finally hit boost at 8300 (is that normal for the size turbo?) and then it goes up to about 0.800? I'm not too familiar with running methanol, but will the plugs look black if they are fouled out? How do the plugs look/smell?

Not sure if you ever got this sorted out or not... But, since you said the car runs perfectly fine in "Traditional" fuel equation mode, it could be that some of the information given to the ECU when fuel equation mode is set to "Modeled" is wrong. With "Modeled", you have to provide the engine's displacement. 2100cc seems like a rounded number and could be throwing off the calculations. You also have to provide the correct flow of the injectors in CC. Perhaps the data given on the injectors in terms of flow is wrong? Or the injectors you received are not the injectors you ordered? Might be helpful if you had the injectors tested.

Hate to dig this up but I am having the same exact issue. Anyone ever get to the bottom of this?

If your VE numbers are larger than realistic (say >130), then it usually means the engine is receiving less fuel than the ECU thinks it is commanding. There are many inputs into the modelled fuel equation so unfortunately, that means many possibilities where there could be an error but the first things to check are that fuel pressure is controlling well at the value set in the ECU and that the actual injector flow rate matches the value set in the ECU (test an injector yourself if you dont have reliable data).

If you attach your tune file and a log here I will take a quick look if there are any settings out of place.

Hey Adam,

So I wired a FP Sensor to the car the and FP is solid all the way to about 5500 rpm still. I had a log but the windows update got me on an automatic restart. After all this I still seem to be having the same issue. I looked at the log and I noticed that the Duty cycle is at 40% but the VE table is maxed out at 150, any ideas on what could be causing this to be so out of calibration?

for anyone that want to take a look I did a log till I was close to running out of VE number. If anyone has any input that would be great. I have wired up a FP sensor since the last post and the duel pressure seems to be spot on. I am completly baffled as to why this is being so difficult.

Attached Files

What fuel are you using? You have your fuel density and density temp coeff set to Ethanol values but have set a stoichiometric ratio of 14.7.

You should also update your firmware as that is running a very old version.

We usually reply within 12hrs (often sooner)

Need Help?

Need help choosing a course?

Experiencing website difficulties?

Or need to contact us for any other reason?