Sale ends todayGet 30% off any course (excluding packages)

Ends in --- --- ---

MLS Motec

General Tuning Discussion

Forum Posts



Tech Articles

Discuss all things tuning in this section. News, products, problems and results. 

= Resolved threads


I have had to download dosbox to run the old MLS motec software with my computer, have this up and running but cannot connect to the ECU. Does anyone have any experience with this?

Is your windows 32 or 64bit? Dosbox is pretty flaky with USB to serial adaptors and 64bit OS. It should work ok if the laptop has a real serial port though. If you have 32bit windows you dont even need dosbox and can run the motec software directly in windows with a few tricks.

Thanks Adam, yes is windows 10 and it is 64bit and does not have a serial cable port so not looking good for this combination. would you advise just using another PC for this application?

A 32bit pc is certainly much less drama. If you can you attach a copy of your dosbox.conf file and mention which port number your USB adapter gets assigned in device manager I will check your .conf is setup correct but I do know many people struggle with 64bit/dos/usb>serial.

I've ran mls through dos box on a win10 laptop in a 64bit environment before

Thanks Adam, I was unable to attach the file due to security blockage.

it will probably attach if you put it in a .zip, otherwise use google drive or onedrive etc and share a link

Have attached the dosbox file I am running the MLS motec software in. Have since learnt that most people I have talked to have had very little or no success with connecting to the ecu with this system on 64bit windows 10 since some of the recent windows updates.

Attached Files

There is no conf file in the zip - just a windows shortcut

I would just echo that it can be tricky - not totally the same but I have only been able to get my computer to connect to an even older Motec using an FTDI based USB / serial adapter. Using an older laptop on XP it works great ... however once I used dosbox on a newer one I get errors as dosbox doesn’t like FTDI. Now it worked... but having dosbox reporting errors is not confidence inspiring.

Do you have an older laptop you can borrow?

(edit - I also connected to it fine with a laptop with a native Serial port, but those are hard to find these days)

to be fair I've not tried connecting using DOS box for probably the best part of a year so it's likely the newer updates might be causing issues

Thanks for your help with this, now have it sorted. The above convesations lead me to find that the only way I could get a connection was using a windows7 computer with a direct serial port and serial cable and not through a USB adaptor.

We usually reply within 12hrs (often sooner)

Need Help?

Need help choosing a course?

Experiencing website difficulties?

Or need to contact us for any other reason?