Sale ends todayGet 30% off any course (excluding packages)

Ends in --- --- ---

Motec M1 BRZ RPM Cut Issue

General Tuning Discussion

Forum Posts



Tech Articles

Discuss all things tuning in this section. News, products, problems and results. 

= Resolved threads


i am having issue with Motec M1 BRZ

engine is fully built and have hks cams and port injectors is id1300 and keeping the stock DI injectors

the problem that i have like a fuel boost cut approx at 6700 rpm and i lost throttle,afr seems fine and rpm steady

i tried looking at the limits and increased them all and set rpms limit to 8000 but i still have the issue,any help would be appreciated


Attached Files
  • Toyota-86-2012-FA20D-01.07.0009-February-2015-Manual-Transmission-OE-Injectors-+-1300cc-02-test-2.m1pkg-archive
  • Attachments may only be downloaded by paid Gold members. Read more about becoming a Gold member here.

There isn't really enough information to give you a conclusive answer. When you say you 'lost the throttle', do you mean the dbw throttle stops functioning? If so, this could be that the ECU is detecting a dbw fault. Have a look in your time graph at the point where the issue occurs and check the throttle diagnostics. You can also log the fuel cut state and ignition cut state to help identify what is introducing the cut.

As Andre said, logging of the issue, or looking at the live data through the Time Graph is needed to diagnose and resolve the issue.

well something is odd,the dbw states is good no fault codes,no ignition cut count or ignition cut event,rpm limit state is maximum and and i logged fuel and ignition cut states and i don't see anything to start activatng but the car still cuts at 6400-6700 rpm

any clues

i also set the PI fuel to 100% in boost

here is the pic of the errors i get and last map i have

Attached Files
  • error-1+.png
  • Attachments may only be downloaded by paid Gold members. Read more about becoming a Gold member here.

  • error-1.png
  • Attachments may only be downloaded by paid Gold members. Read more about becoming a Gold member here.

  • Toyota-86-2012-FA20D-01.07.0009-February-2015-Manual-Transmission-OE-Injectors-+-1300cc-samA.m1pkg-archive
  • Attachments may only be downloaded by paid Gold members. Read more about becoming a Gold member here.

here is a video to view the issue,the car feels like hitting a wall,i tried 50-60% throttle it can rev to 8000 rpm no problem.

Attached Files


Can you change the Vehicle Speed Limit Maximum to 6000kp/h, as you are showing errors with the Wheel Speeds this may be causing the limiting.

Also, Is there a reason that the Voltage Reference's for the Throttle Pedal and Servo have been changed to Absolute?

It doesn't appear that the ECU is instigating a cut in the time graph which doesn't really help much. I've got a few more questions though:

1. What fuel are you running on? Your configuration is set up for pump gas but you're seeing 66% IDC from an ID1300 at 6100 rpm and on pump gas this should be enough fuel for around 600-650 hp - I'd be impressed if you're making that. This is assuming you've swapped to a manifold pressure referenced regulator/fuel system - How is this set up?

2. While not strictly related to your issue, I wouldn't recommend running solely on the port injectors. Particularly if you're still running the stock CR (I'm going to guess given the boost pressure that this is a built engine), the DI is a big help in reducing the knock sensitivity of the engine. There is also a theory that sounds sensible but I can't confirm, that the DI injectors also rely on fuel passing through them to remain cool and hence running no DI can result in damage to the injectors.

3. Your mixture aim table currently only extends to 120 kPa. This should cover the entire range of rpm/load you're likely to encounter. I'd also take a wild guess that you're not really wanting to aim for 0.89 lambda at 230 kPa? Out of interest what is the actual measured lambda at the point just before the engine hits this limit?

4. I'd suggest looking at the actual throttle position vs pedal position. The ECU isn't requesting a cut so it would appear that potentially the ECU is closing the throttle.

Apologies, ignore my last point - I see you are displaying throttle position in the time graph :(

I think BlackRex's comment might be on the money. With the Feb 2015 firmware, the front wheel speeds default to 3317 km/h (or something similar) when you run the car on the dyno and the front wheels don't turn. This caused a lot of issues after this update as the car would essentially be impossible to run on the dyno. The key was to max out the vehicle speed limit maximum setting.

Typically you would see this problem earlier than you are though which still leaves me wondering. For example when I found this issue it would happen almost as soon as I started driving on the dyno. I notice your speed limit however is 500 km/h while the default value is 300 km/h - I'm unsure but this may have something to do with you being able to get through to 6100 rpm?

Hi Andre,

Your point 2 is correct, in that the DI injectors should have some fuel being injected when the engine is under load to assist in cooling the injector and preventing it from being blocked by carbon build up.

Black Rex,

thanks for the tip about speed limit i will try it and report

its my first time i do motec m1 and FA20 too i just need my hands to get quicker into the software and i am really happy with your thoughts.

for the throttle servo,i had it on throttle 5 0V on previous settings,i had error with throttle warning and i copied this from the motec 86 basemap to check if i have wrong settings,and i lately it was just offset calibration,i will get it back to where it should be and recalibrate.


the engine is fully built block and head and gtx35(a small version turbo) have same compressor wheel but turbine and compressor housing is smaller.

i am running a good 98 octane actually and car is making 495 whp at 1.4 bar peak at 1.3 at peak hp right now but i think the ecu is miss calculating the duty cycle as the secondary injector reference flow is kept at 1000 cc from previous injectors that's why i still see 66% idc at 6100 rpm, this is changed later.

running solely is PI on boost i didn't feel comfortable with,i reported the problem somewhere and they asked me not to run 50/50 or 70/30 as i supported the maps as the DI would not be able to keep up as 6ms all it can handle and causes spark blow out

i can see the target lambda maps i will fix it,i will certainly fix that today,will it affect the open loop fuel table ? which setting? current afr is 11.5-11.8 on peak boost to redline

one last things,i feel i am maxing out a maf signal or sort of,the car dont make that cut at 1.4 bar but it makes it at 1.6 bar,thats the last thing i discovered,however all my limits are set to maximum except the wheel speed limiter as you said,

someone told me turn boost control mode on and set aim boost higher than the actual i get as a closed loop mode.

i am not sure what to do further

thank you guys for all the thoughts and help.

Ah that makes sense. Looking at your calibration it was a safe bet your engine wasn't stock. I know a lot of tuners overlook the fuel characteristic settings in the M1 though when they tune on E85 so I thought I'd ask. You didn't mention the fuel system though? Have you switched to a retrun style fuel system with a pressure referenced regulator? At 1.3-1.6 bar your differential pressure will be getting down to 240-270 kPa which will affect the injector flow as well as perhaps affecting the atomisation you're achieving

I'm using around 40% PI in my secondary contribution table on E85 and 170 kPa boost. I would simply adjust the PI ratio and keep an eye on your primary injector pulse width. Adjust it to maintain a pulse width at high rpm of around 6 ms max. It's not too difficult to do.

The VE fuel model of the M1 requires you to start by adjusting the mixture aim table to your desired targets. You then adjust the VE table until the measured lambda matches your target. If you do this correctly then you can further adjust the mixture simply by changing your target. Press the 'A' key for axis setup and you can extend the load axis to suit.

The M1 doesn't use the MAF signal for any calculations at all. In the stock package the MAF sensor is read but this is simply for logging purposes and will result in the channel 'Airbox Mass Flow'. It's interesting to compare this to the inlet mass flow channel which is the calculated channel the ECU uses based on the VE numbers and your fuel/engine/injector configuration. So ultimately no, the MAF isn't your issue. Right now your boost control system is disabled and the time graph you posted shows no fuel or ignition cut becoming active so I can't see this being your problem. Personally I'd use the M1's boost control system as it works exceptionally well and then you can configure an overboost cut for engine protection.

You say the issue you're talking about happens at 1.6 bar and not 1.4 bar, but the time graph you posted shows the problem at 1.3 bar boost? Have you tried running the car with the speed cut maxed out yet?

Hello Andre

DI system is completely stock just id1300 and upgraded rear pump

i did the wheel speed limit to 6000 and to 99999 and infinity but i still get the error,i also tried to make the throttle limit to 100% but didn't make a difference,

the weird thing i left the dyno last time with the issue not appearing at 1.3-1.4 bar but appearing at 1.6 bar and now things are different the cut happens at 5500 rpm and lower boost.

this is the last map and screen shot of event log

Attached Files
  • error-log.png
  • Attachments may only be downloaded by paid Gold members. Read more about becoming a Gold member here.

  • Toyota-86-2012-FA20D-01.07.0009-February-2015-Manual-Transmission-OE-Injectors-+-1300cc-5500rpmerror.m1pkg-archive
  • Attachments may only be downloaded by paid Gold members. Read more about becoming a Gold member here.

Have you considered that it may just be an ignition/ spark issue and nothing to do with the ecu itself?

EDIT: Just watched the video and that certainly doesn't look like what would happen with a severe misfire so ignore my post :)

Hi Sam,

Can you please post the logging, the package and screen shot do not provide the information needed, and that is why MoTeC included level 1 diagnostic logging in all of the packages.

Hello everyone

sorry for the late reply,

yes it turns out to be something related to the ecu at all,i been guessing something from the beginning and it turned out to be the issue

i did ecutek map and had same issue

eventually it turns to be the turbo inlet hose collapse at high rpm,its samco hose and i think from sort of heat if became weaker by time

thanks a lot for everyone who helped with thoughts and gave tips and sorry to tell that how simple is it but sometimes we don't see the issue when we think it's something big.

i also learnt few tips from you guys and happy about it,that's the reason of the discussion ;)

thanks again.

We usually reply within 12hrs (often sooner)

Need Help?

Need help choosing a course?

Experiencing website difficulties?

Or need to contact us for any other reason?