×

Sale ends todayGet 30% off any course (excluding packages)

Ends in --- --- ---

SR20 Ignition Timing Conundrum

General Tuning Discussion

Forum Posts

Courses

Blog

Tech Articles

Discuss all things tuning in this section. News, products, problems and results. 

= Resolved threads

Author
384 Views

Hi folks,

I have a bit of a tuning debacle that has been plaguing me for some time now, and I was hoping to get some potential insight/suggestions/advice – specifically regarding ignition timing

I have got a non-VCT SR20DET with some fairly basic mods currently running about 18psi and making in the vicinity of 350rwhp.

-Head studs + Headgasket

-Garret GTX2867R Gen I Turbo

-Adaptronic e420c ECU tuned on e85

-Standard cams (was 264s until it threw a rocker and bent a valve a few years ago…)

-LS1 coils

-Other basic misc supporting mods not worth mentioning

The issue is that when we were tuning it and increasing the boost levels, it started to develop a misfire – and the higher the boost the more it missed.

The misfire seemed to occur at about where peak torque is then clear up again as it reached higher RPM.

There was good battery voltage, closing up the plug gaps made little difference, and playing with AFRs didn’t seem to make much difference either.

We were able to tune out the misfire by adding in more timing advance, to the point that to run the 18psi of boost without a misfire the engine was wanting about 40 degrees of timing, and it seemed to actually be very happy there…

I was wondering whether it could be an ignition coil issue where with more boost and (relatively) retarded ignition timing the combustion mixture was more compressed and therefore harder to ignite? But I would have found this to be unusual with running LS1 coils as I'd have thought they would be more than up to the task.

Anyway, has anybody else found this to be the case? Is there something that maybe we’re not considering? Or is this where the spritely little SRs like to run on e85…?

Many thanks for any input / insight :)

There was a round of these questions on Ausrotary and some other forums 10 years ago when a lot of people were starting to take up ethanol or water injection and push turbo stuff into higher boost without going to more drag focused CDI system. It is weak ignition. Don't seem to be too many problems for those running IGN01A or GTR coils with decent dwell, LS1 coils with reasonable dwell and gap were usually ok but not at the same level as the others, many guys back then were still going to varous CDI options too. Rare metal plugs with small radius electrode tips will spark over at lower voltage too.

It was still the era when guys with dynos went to the effort of posting dyno run data with good descriptions and posting again after switching to an alternative ignition system with exactly the same tune and it was pretty obvious what was going on. I think a well repeated line by a character who ended up with a very poor reputation for other reasons but was right on this was [have the right gear to] tune your engine, don't let it tune you.

Have you compared your dwell to what others are running? Are you running rare metal plugs?

No I would say something else is wrong. Have you confirmed actual timing is matching commanded under load? Is the timing stable under load? Have you confirmed the TDC mark - the dampers on SR20's are prone to debonding and slipping around.

I haven't compared dwell to what others are running but am running 3.5ms from memory. I'm not running rare metal plugs. Am running NGK R5671A plugs in either a 7 or 8 heat range.

The only thing we've been able to come up with is weak coils/spark. So the next logical thing we were going to try is a gtr coil kit.

Good suggestions there Adam - we have had a timing light on under load through a dyno pull and the timing checked with timing light corresponds to what is requested by ECU, and is quite stable throughout.

We checked TDC mark as well, and it corresponds pretty well with TDC on cyl #1.

We checked these things because we too thought it just didn't seem right and there had to be something else going on...

@Adam@Link_ECU , I'm very curious why you dismiss ignition strength when he hasn't complained about changes in idle quality or drivability, only misfire at at peak VE where charge density is highest? That is classic weak ignition signature? Sure power impulse is high there too so depending on triggering set up stuff with cam driven triggers may have issues with slop/elasticity but recovering from miss with over advance on water/alchy fuel is again a classic weak ignition symptom? Genuinely want your insight as I have no doubt you do a lot of remote fault finding.

Just experience, 18psi and 350hp on e85 is hardly pushing the boundaries. The stock SR ignition system will generally handle that sort of level no worries and the LS1 coils are a reasonable improvement above those. Typically if you have an ignition energy issue if you reduce plug gap or retard ignition to lower cyl press the misfire will reduce. SR’s typically don’t even like much more than 40 deg at full vacuum never mind full load so something more feels wrong to me.

What about the situation where a weak ignition system is unable to ignite a higher pressure A/F mixture closer to TDC? Would this technically be able to be overcome by advancing the ignition timing and igniting a lower pressure charge?

Yes that is the exact effect I described, people over advancing to work around ignition system weakness, as Adam said, usually would happen at higher boost than where you are. Are they genuine coils? Not knockoffs?

Yeah, it's what I had logically thought was the most likely culprit too.

Coils are genuine OEM items, but were sourced 2nd hand from a wrecker engine - so I suppose their condition may have been questionable from the outset. Even re-did the wiring to ensure a more than adequate power and ground, but that didn't make any difference either. So next logical step is to try a different set of LS1 coils, or go to a GTR kit.

So problem has been solved!

I tried a few other things with no success including a different set of LS Coils.

In the end it turned out to be a faulty plug lead! Put a different set on and problem gone completely!!