Sale ends todayGet 30% off any course (excluding packages)

Ends in --- --- ---

Subaru Flash Tune *oopsieI*

General Tuning Discussion

Forum Posts



Tech Articles

Discuss all things tuning in this section. News, products, problems and results. 

= Resolved threads


2006 ADM XT Forester MT

full bolt ons

was making up a base map, to account for new intake exhaust and more importantly 850cc injectors over the stock 565cc, to atleast get the car to start and idle. no big deal, got it to start, had terrible idling, wouldnt stay on, tried a few things here and there, anyway while going to flash one of the new maps...i maybe, possibly could have potentially (i 100% did) flash an 05sti map, well it failed like i expected but thought nothing of it, so i went to flash the map i meant to, it also failed. now, i cannot read or write to the ecu, fuel pumps not priming with ignition on, i dont have cruise or cruise set lights on any more

using ecuflash, romraider and tactrix openport 2.0

my question is what the hell have i done and how do i possibly fix it, or atleast what can i try

ive disconnected the battery overnight, tried cranking with and without test mode wires connected, it still ramps up fans and clicks all the relays without the test mode wires connected (green connectors)

tried flashing stock map with the same fail message

[13:32:35.232] J2534 API Version: 04.04

[13:32:35.232] J2534 DLL Version: 1.02.4798 Jun 13 2016 17:17:10

[13:32:35.232] Device Firmware Version: 1.16.4769

[13:32:35.232] Device Serial Number: TAMBWZ6X

[13:32:35.419] SSM2 init

[13:32:35.566] SSM2 ECU ID is 3D12594006

[13:32:35.650] Requesting Seed...

[13:32:35.689] Sending Key...

[13:32:36.345] interface close

[13:32:36.345] interface close

heres the log of trying to flash stock map

It sounds like you have potentially bricked the ECU. I've been fortunate that in my entire career reflashing hundreds of Subaru vehicles I've never ended up with one bricked so I can't speak from experience. If I'm understanding you correctly it appears you've tried to flash an incompatible ROM image into your ECU which is something you really want to avoid at all costs. This is why in our Practical Reflashing course starts by downloading the existing ROM from your ECU, saving and then modifying that. If you can't flash the stock ROM file into the ECU then you may need to look into recovering the ECU. I haven't done this myself however there are a few resources covering the process. It's fiddly and time consuming but not overly expensive to do. https://forums.nasioc.com/forums/showthread.php?t=2200443

Yes that was my worry, I can however still check and clear codes over obd2 which leads me to believe not all hope is lost

It was by mistake as ecuflash says that the flash method is 05sti and being on little sleep eager to get it running I clicked the wrong image file (an image actually for an 05sti) rather than the one I edited

I have purchased the course and have been watching, total fault on my behalf trying to blast through

When a flash fails, never never turn off the ignition! Just leave the key on and try to flash a good known ROM and it should do it.

Good to know! Now I know what can brick an ecu I'll definitely be more careful

Issue has been fixed and will be sorting out the maps through the week

We usually reply within 12hrs (often sooner)

Need Help?

Need help choosing a course?

Experiencing website difficulties?

Or need to contact us for any other reason?