×

Sale ends todayGet 30% off any course (excluding packages)

Ends in --- --- ---

Trigger Issues with Civiclink PNP

General Tuning Discussion

Forum Posts

Courses

Blog

Tech Articles

Discuss all things tuning in this section. News, products, problems and results. 

= Resolved threads

Author
132 Views

USDM 99 civic si b18c with stock distributor. Car will crank no start with the link ecu. I’ve adjusted the arming threshold and filtering with no luck. Car will run on the socketed ecu. Any help is very appreciated. I have scope files but it will not allow me to upload them.

Attached Files

Christopher,

The 96-99 civiclink base file from Link appears to expect a single cam pulse per 24 teeth, but just by eye you're getting 2 teeth in the first image, then things look more what I'd expect in the second image. Admittedly I didn't count the teeth in the image, but once the engine gets up to cranking speed are you seeing 1 cam pulse per 24 crank teeth?

Do the teeth overlap or no? Zooming in helps double check.

Is RPM reading properly? Are you getting triggering errors?

Please let me know and we can continue from there.

I’m getting trigger errors. I adjusted the threshold up until the ignition noise disappeared that you’re seeing in the first picture, but I’m still getting errors. I have counted teeth, and have even tried another distributor. The rpm will register correctly then fall out in a repeating sequence. The car randomly started one time and hasn’t started since.

Well the good news is it sounds like you're close, and that info does help narrow things down. Where do you have the filtering and arming thresholds set now?

Right now .5v on trigger 1 and 2v on trigger 2. I’ve tried adjusting at .2v increments on both triggers with no luck. The ignition spike goes away when it’s set to 2v on trigger 2.

Sorry, can you explain "ignition spike"?

Are you saying you get some ignition with that setting and none with something else?

You can choose arming thresholds based on the values recorded in the scope log, by zooming in to see what the consistent voltages are. If you upload your scope trace file I can take a look.

The spike that was on the trigger 2 scope picture before changing the threshold. It was so consistent at that point that I was contributing it to noise from the coil. The stock distributor has the coil built in.

I’ve tried to upload my scope files but it won’t accept them. Says I cannot upload a .llgx file.

To upload unknown file types, just put them in a .zip file (which is also called a Compressed Folder in Windows). The .ZIP files can be uploaded.

Here's the scope files. Thank you all for the help.

Attached Files

Chris,

Thank you for this. It's now far more clear what's going on.

In this screen shot taken from one of your scope traces, you can see the waveform itself is malformed and has a great deal of noise in it. In the trigger 1 trace peaks aren't being properly reached in a number of cases, and in both trigger 1 and 2 traces there are spikes occurring. Some random spikes in trigger 2 are so large I don't believe you can avoid false edges via arming adjustment.

""

Given the magnitude of the random spikes, I suggest looking into reducing noise in the systems.

Does the vehicle have all factory wiring?

What coil do you have?

Has the harness been tucked or re routed at all?

I would check your battery terminal connections, engine harness ground connections, and vehicle ground connections. I have my fingers crossed this is mostly caused by poor grounding which is often a pretty easy fix. Perhaps were any ground points painted over?

Update on my issues; It’s on a factory harness. Performed voltage drop test on all wires to and from dizzy and found no fault. Verified shielding in place and correctly grounded. Verified main battery grounds. I even bought a new ignition control module for the dizzy and tried that with no luck.

Out of frustration I’ve order a new trigger kit from 5-0ignite and harness from rywire.

Any update since then?

We usually reply within 12hrs (often sooner)

Need Help?

Need help choosing a course?

Experiencing website difficulties?

Or need to contact us for any other reason?