×

Sale ends todayGet 30% off any course (excluding packages)

Ends in --- --- ---

Unsatble rpm and weird laptop connection issue

General Tuning Discussion

Forum Posts

Courses

Blog

Tech Articles

Discuss all things tuning in this section. News, products, problems and results. 

= Resolved threads

Author
1549 Views

Hi everyone

Link storm g4+ Suzuki swift m16a sports engine in a jetboat

Has anyone had a issue like this before?

Can not at all get a stable rpm or idle to adjust my ignition and fuel tables, set base timing to 10deg and idles perfect as is locked, hit enter, then revs bounces up and down like its hunting, look at my ignition table set the cells the crosshair is going to and from to 10 and still doesn't change. so thinking its not a timing issue?

Playing around with my fuel table doesn't help at all. I cant even use autotune as cant hold rpm in a certain cell.

Then I unplugged pc cable and idle increased dramatically and slowed down the hunting a bit but still un tuneable. I have no idle control valve. so slow idle down and is a bit smoother again but still not good enough at all. I'm not sure if this is a ecu, laptop or engine fault, thinking its not a engine fault such as a air leak because when I set base timing it idles perfect. Have been sent a tune from another m16a engine just to get me started.

So anyone experienced this or any ideas to help me out? can post up a video what's happening if I can post videos on here, but I think iv explained it good enough :D

Hi Matt,

The fact that you are working off of a base tune from the same engine I would think the map is fine, what would help would be if you could post a datalog of the engine running, record timing, AFR, ECU voltage, manifold pressure, IAT, and anything else you might think would help. If there's no issue with sharing a copy of the map then post that too as it will help being able to see the entire picture.

I've written a quick how-to for setting up a datalog here:

http://dynatune.co.uk/little-black-box/

Matt,

As Chris said above, a data log or copy of the tune would be helpful.

When setting the base ignition timing, this removes all ignition trims so my thought is possibly an issue with a certain ignition trim.

Press 'R' or F12 and this will bring up your run time values, select the ignition tab and watch what your timing is doing while idling.

I have seen before when idle ignition control has been switched on and map lockout will be 60kpa (random number) although engine bounces around 58-62 kpa which will cause it to come in and out of idle ignition control. This makes the idle very erratic.

Link is a great product although I have also found a few bugs when uploading a map onto an ecu, quite often it can become corrupt and alter certain settings, mostly I find it is post start enrichment, warm up or ecu hold power settings. I would go through all your settings and ensure they are correct.

heres logs

Attached Files

base map

Attached Files

ok I think I have messed this logging up, let me know if I need to redo it, played around with configuration started engine and idled perfect, then started to slowly pack up, then died, realised 5v spare wire had earthout out took me a while to find lol. but after that everything went weird, running like it used to and worse, so here are some more logs, from what im reading from it I can see when it was running good then readings went out the window so im guessing that's when my 5v was earthed. I think you would like me to re log, so I can I just had enough with it tonight. starting to understand the logging side so will get a good log sometime.

and ok will go through and check everything gets a bit confused I haven't figured 100% how to work my way and understand it.

cheers

Matt,

I can see in your log what you are saying about the 5v signal earthing out.

As for the other log of the idle fluctuating, what is you afr at idle/at this point? At a guess I would say it is quite lean going off the ECT, Warm up enrichment and your current Master fuel. This will cause the fluctuation which in turn will change MAP and also cross from your 1000rpm to 1500 for your ignition timing so that will start to swing make the situation worse.

I noticed you're using TP as your load axis for ignition timing, is there a reason you have chosen this for this particular application?

Once the 5V issue was sorted has the laptop connection issues stopped?

can you not see the afr parameter? its rich, 11-7, and I cant bring a cell to afr targert the afr will not change at all. I found I had my map sensor hose was t into my fpr hose, changed them to separate points on engine and now is running much much better, still not perfect though.

No reason I just simply loaded in the map and started playing around. haven't put in water yet to start adjusting ignition and fuel, should I be using map instead?

cheers matt

more logs

Attached Files

if you look at your ignition table you have cell 0TP/1000RPM with 15.9degrees and then in the neighbouring cell 0TP/1500RPM you have 23.1 degrees, the ECU will be interpolating between these two and add a column at 1100 or 1200 and copy your 1000RPM column into it

Matt, I can see your AFR although it looks as though there is an issue with the sensor or wiring as it sits at .73 lambda and doesn't really move. If this mixture is true I would be expecting it to pump out black smoke, which I am assuming it isn't?

Also try and stabilize your ignition timing, Like Chris250 said either copy your column over, set that whole area of the map to 10degrees for now or turn on and setup your idle ignition control.

We usually reply within 12hrs (often sooner)

Need Help?

Need help choosing a course?

Experiencing website difficulties?

Or need to contact us for any other reason?