Forum » General Tuning Discussion » VQ30DET + EcuMaster Emu Black Start-up problem

VQ30DET + EcuMaster Emu Black Start-up problem

General Tuning Discussion

Discuss all things tuning in this section. News, products, problems and results. 


Page 1
Author
173 Views

Hey guys!

I wonder if there is anyone who've managed to start vq30 using ecumaster.

We have stock vq30det with big turbo, upgraded injectors, intercooler and few external mods.

For primary trigger we use 350z flywheel with stock vq35de crank sensor.

Secondary trigger is stock camshaft sensor of vq30. Since Ecumaster does not allow to manually set number of teeth on the camshafts and forces to use it's presets we had to shave all teeth from it except one and choose 1 tooth setting in the software.

We have managed to get correct scope of incoming signal from both primary and secondary triggers and it successfully synchronizes. We have double checked every output, spark is in place, injectors are working, fuel is pumping, tdc is set-up for cylinder 1 and doublechecked with strobe, ignition order is setup according to manual 1-2-3-4-5-6. But still we can't get it to start. It tries to do that sometimes but it is very inconsistent and we didn't get a chance to start it at least once.

I was thinking of incorrect angles or fuel amounts but we tried almost everything we could and still no success. EcuMaster support team ignores my emails and my dealer doesn't know how to resolve this.

Can anyone help?

P.S. I have all logs and scope files if there will be anyone who would like to take a look at it.

Thank you!

Have you actually confirmed the timing with a timing light? Are you seeing something sensible during cranking - Somewhere in the region of 0-30 degrees should get you running. If the timing is in this vicinity it may also be that you're firing on the exhaust stroke. Try adding/subtracting 360 degrees from your base timing offset and try that. I'll also assume you're getting fuel injection occurring - Have you checked this?

Thank you for reply!

Yes, we have confirmed it with the light.

We almost had it running but it only lasts for several seconds and then shuts down. I have been thinking about incorrect stroke and we did offset of +3 (this way ecumaster will fire 4-5-6-1-2-3 instead of 1-2-3-4-5-6). During these attempts it was sneezing and jumping around 300-750 rpms but didn't get to stable rpms at all. We could also hear that some of pops were jumping to the intake, so I assume that we are still on the incorrect stroke (even though we have applied the offset, and ecumaster does only allow to move offset forward and doesn't accept negative values).

Injection is happening and fuel is getting into, that's correct.

Could it be that we have incorrect firing order? (1-2-3-4-5-6 is taken from internet manuals for vq30det)