×

Sale ends todayGet 30% off any course (excluding packages)

Ends in --- --- ---

Throttle Response Issue

Off Topic Discussion

Forum Posts

Courses

Blog

Tech Articles

If it's not really about tuning or wiring. Then it belongs in here.

= Resolved threads

Author
1749 Views

So I'm trying to start tuning on my car and the mechanic says we have a problem. He revs the motor three times from the TB and it responds fine the first two revs, but then when he opens it the third time in a row, instead of revving the rpms fall as if he had revved and then closed it.. It takes a couple seconds before it realizes it's supposed to be open and then revs back up again. I don't have a clue what could be wrong. He seems to think it could be a tuning issue or a communication issue, but is stuck as well. The car currently has a 3 bar and TPS w/500 miles on them, and I've ordered a brand new 4 bar and TPS just in case. I don't have access to the car right now because of the Italian holidays, so I'll have to wait until he returns to troubleshoot any further. I'm just curious if anyone has had this happen before, or any thoughts on how to troubleshoot it?

Just to clarify, this isn't a sluggish or delayed response. The first two revs are fine, then it acts as if he's not revving it and the rpms fall down for a few seconds and then it revs again. This happens roughly every third rev over say 5k. The mechanic doesn't speak English so our conversations are limited as well.

Info:

B16 bored to 82mm

GT2871R

OBD-1 conversion

Hondata S300

Omnipro 3 bar

BWR TPS

Omnipro 68mm TB

Full specs are on my build thread: 91 CRX

you'll need to get connected and datalog what's going on, record throttle input, injector duty, timing, rpm initially to see what's actually happening

I did.. but I can't make heads or tails of it because it's my first time ever messing with tuning. I posted the datalogs to Hondata but no response. I can post them here maybe but can't tonight.

Post the logs here as well as your calibration if you can. Chris is right, the first step is to diagnose what is happening from the log.

Sorry for the delay, had to run out of town for a few days. I'm attaching the last log I ran. Not sure how to load my calibration, but it didn't seem to make a bit of difference. The tuner ran a roughly stock base map, and then I came in and downloaded something similar to my setup (B16 turbo w/1000cc injectors) to try, we both had the exact same issue. I'm hoping it's just the TPS, my new one should be here in a day or so.

[EDIT] or not... it's not letting me upload my logs.. .s3d extension. Is there a way to convert these files into something useable here in the forum?

Try zipping the files. The forum is a little fussy on which file extensions it will accept.

Thanks! Here are the last 3 logs I did.. A friend was trying to help me with the idle when the mechanic came to me and told me about the problem.

Attached Files

Any chance you could post a screen shot? I don't have any analysis software on my tablet :-)

Here is a screen shot of one of the logs. It's really hard to see what's going on, at least to me. As I said, we pull the cable and it responds perfectly fine (usually about two times) and then on the third or so time it just doesn't respond at all for what seems to be about 2-3 seconds. The RPMs fall off as if we let go of the cable completely, yet we're at WOT. Once it realized that it was open and started to rev, we let go. Based on the log, the best place I could see it is marked on this screenshot, but it doesn't seem to relay the delay as we were seeing it. I believe we re-created it further down the log, but again, it doesn't really show anything that I can pinpoint.

Attached Files

I dont actually see the TPS signal change in the log, go to parameters and under tps hit calibrate, on a honda you should have about .45-.55 volts when tps is closed and about 4.5v when its open, you might have the wires crossed.

Your car is running way rich if the wideband is calibrated correctly. Can you post your calibration file and I might be able to help, what injectors and base fuel pressure are you running?

l TPS has 3 wires

They are

1. Refrence Voltage +5 Volts

2. Sensor Ground

3. Output from TPS.

Your ign s/w should be on. (Car may or may not be running)

Then check the voltage between sensor ground and Sensor out for throttle closed and open.

As you open your Throttle you want the voltage to slowly climb from .5volts to 4.5 volts with no major jumps.

Tommy, thanks for the assistance. I'm posting the calibration below. Let me know if you require another format. I'm also posting my log from today as a screenshot. They didn't hook up my gauges yet so I'm sure she's probably rich for sure.

I was able to get to the car for the first time in about a month today. I swapped in the new tps and 4 bar, but I believe the spring inside the tps popped off after install. Before, the car held idle, and today after the new one was installed it wouldn't. I did make the adjustment from the 3-4 bar in the calibration. I was able to rev the motor, but still had the same issue as before with the throttle response, only this time it wasn't roughly every third rev, it was completely at random. I tried adjusting the minimum idle rpms to keep it at least running, but it had no effect. I was also getting an IAT error before, and this time I received additional errors.

This is aggravating.. I'm wanting to learn tuning, but at the same time my car has been sitting at this shop for over a year now and I still can't even bring it home to play around with it. I'll see about the voltage issue when I can get back over there again. If the problem is anywhere, it will probably be at the wires going into the ecu. I checked the wires in the bay and everything looked fine (didn't have my tools with me).

Anyone know of someone who can, and is willing, to e-tune my car? After this problem gets resolved of course..

Attached Files

That calibration def needs some work but first you need to get the basic sensors squared away before you start tuning. I believe you have a wiring issue, even if the tps was installed incorrectly meaning the plastic tab on the TPS was not installed in between the two metal tabs in the throttle body you should still see some voltage. Your issue is 100 percent wiring related. If the ecu does not have TPS signal than that would explain your issue. Test the wiring and make sure you have the correct signal going into the ECU. Check PIN D6 for voltage.

In Smanager you should see this value change (see attached screenshot)

Attached Files

THANKS! Yeah, I've been trying to run down the issue for a while now without access to the car and no one here who really knows much about Hondas anyway. I hooked the ecu up and converted it to obd1 on my previous build with no issue, but when we started it up this go-round it started happening. The only thing I really changed was adding the s300.., same tps mounted on same tb, just know sometimes things go bad.

Ive seen people swap parts without diagnosing the issue and its always a headache. i would check the wires going to the tps and also check for continuity from the tps plug to the ecu, without a tps signal it wont work, any competent mechanic should be able to help you out, in the screen shot you showed you were getting codes for iat as well as cyl 9 code for tdc sensor it def sounds like you might have bunch of wires miswired or broken, did you use a step down harness to convert to obd1 or did you wire it yourself? If all is good then maybe ecu is bad

I used a step-down. Like I said, everything worked fine before the S300 got installed.. Didn't really even think about that being the issue. The shop is closed over the weekend so we'll see what we can do on Monday. The reason I threw the parts at it is because I had a month of can't do anything with it so I put them on order. I can always use spare parts, but it takes 10-14 days to get stuff here :(

OK cool, check the wiring and then well go from there.

I finally got back into town and squared the car away.. It was indeed the wiring. One of the wires in the harness was bad. We fixed it and are moving on to the dyno next week :) Thanks guys!

Excellent, glad it was something simple for you

its usually the simplest things, glad you got it!!

Nice work on the diagnostics Tommy!

Let us know how you get on with the dyno session Treezy.

Thanks Andre, I know I'm just a grasshopper compared to your skills but I'm trying and learning. =)

We usually reply within 12hrs (often sooner)

Need Help?

Need help choosing a course?

Experiencing website difficulties?

Or need to contact us for any other reason?