Sale ends todayGet 30% off any course (excluding packages)

Ends in --- --- ---

Motec M84 To AEM CD-7 DASH CANBus Issues

CANBus Communications Decoded

Forum Posts



Tech Articles

Discussion and questions related to the course CAN Bus Communications Decoded

= Resolved threads


Hi Guys,

I wasn't really sure where to post this. I feel it would work here as it is CANBus related. If not please let me know.

My current setup is a Motec M84 and a AEM CD-7 Dash. I am not able to get the dash to work and display any data. I have tried contacting AEM and Motec with no success. One says speak to the other. I understand where they're coming from so I'm really on my own here.

I've followed the AEM instructions and yet still have no data.

Few points and what I've done so far:

- I've attached a picture of how I've wired everything up including the resistors.

- Resistance measures 60ish ohms on the AEM dash connector between CAN HI and LO with the ECU connected on the other end (without the UTC CONNECTED)

- With the UTC connected, the AEM dash dash side measures 30ish ohms.

- Resistance measures 60ish ohms at the UTC connector with the UTC removed.

- I am successfully able to connect to my M84 through the UTC with my laptop so I'm pretty sure that eliminates wiring issues ALTHOUGH I've double checked the wiring as well.

- As I have my own resistor on the dash side of the BUS I have the built in terminating resistor set to off in the AEM DASH software.

At this point, I'm stumped. Any suggestions or help here I would greatly appreciate it? I've attached a few screen shots.

Here's the Dash Design File


Attached Files

Have you double checked that CAN Hi and Lo aren't swapped at the Dash? (you know the UTC / M84 is correct and works)

I double checked it right now to be safe and they are wired correctly. Pin 5 is Can HI (White), Pin 6 is LO (Green).

Originally when I wired the dash to the M84, I had wired it in to AEM's Can Port 1 (CAN HUB 1) which are Pin 3 and Pin 4. I then noticed in their instructions they state for third party applications to use Can Port 2 (CAN HUB 2). As I had already wired/crimped my resistor in, I just de-pinned those 2 wires and moved them over.

To save us from any confusion in this post, just in case you looked at the wiring pinout of the CD-7, I was typing out the above reasoning why the wire colors don't match the CD-7 pinout and noticed something when reviewing the instructions.

It reads;

"AEM CD7 has 2 separate CAN ports and for 3rd party devices, AEM recommends you use AEM CAN BUS 2, whose connections are contained in an unterminated twisted/shielded flying lead in the dash harness"

Could this be the reason why it's not working? Instead of using the "unterminated" wires that were originally located on CAN BUS 2, I moved what I assumed are terminated wires from Can Bus 1 in its place? Or would this not make a difference.


Please ignore my last reply. I put all the wires back the original way and still nothing.

You are using some confusing terminology. Did you wire the M84 CAN bus to the unterminated CAN Bus 2 wires from the CD-7 dash harness?

I think you might be confusing buses with the "CAN Ports" on the AEM CAN 4-port Hub. I believe all the ports on the CAN 4-port Hub are on the same CAN Bus (which would normally be CD-7's CAN bus 1)

Sorry about the confusion.

Yes I did wire the M84 CAN bus to the unterminated Can Bus 2 wires from the CD-7 dash harness.

First off, check that your M84 transmit address matches the receive in AEM.

The default is 232, but please remember this is decimal, not hex (the hex address is 0E8)

If you want to check your M84 is transmitting correctly, and you have a MoTeC UTC, I would recommend downloading the drivers and utilities pack, which contains CAN inspector.

This is a program that allows you to use your UTC as a CAN sniffing tool. You just set the bus rate, and and start it, and it will show any messaging that is being transmitted on the bus that the UTC is attached to.

This will give you a pretty good indication of whether the M84 is transmitting any data, you should see items on the Can Id of 0E8 (or elsewhere is you have changed the base address) come up when you start the capture. If nothing is there, you may need to check the settings you have in your M84.

Also the M800 and M84 transmit template have channels in different orders. The first 7 channels are the same, but after that they are all in different locations, so try and ensure you are using a M84 specific template. If the AEM only has a M800 template, if you change the transmit address in the M84 from 232 to 1520, you may see engine speed, map, tps and lambda come across. If this is the case, then you have an issue with the AEM can receive template you are using.

Attached Files

Thanks everyone for all your help so far.

Nathan, in regards to your post.

- The transmit address in the M84 software is 232 and in my AEM Dash software is 0E8 (the software writes is out as 0x0E8)[see attachments on first post]

- Thank you for the tip on the CAN inspector. I was not aware of this program. I did go ahead and run the program and it looks like it is transmitting data. Also on the Can Id column it reads "E8". I've attached a screenshot. Probably unrelated but at first I could not get any data to show until I unplugged and plugged back my USB cable in my laptop.

- The AEM Dash software does not have a template specifically for the M84. The one they say to use is the template called "Motec Hundred Set 3".

- I did go ahead and change the transmit address in the M84 to 1520 and it still did not display any data on the dash.

Attached Files

So the problem is definitely on the AEM or wiring side. I'm still betting on wiring, as your AEM configuration appears to be correct from the screenshots.

Hi David,

I will pull the wiring out of the car to check again just to be safe.

It's safe to assume that if it is a wiring issue, it's somewhere from the UTC connector to the AEM Dash as the UTC works and is currently transmitting data?

Yes -- if it were me, I would reverse CAN2 Hi and CAN2 Low at the AEM 12-pin connector. It's amazing how often this is backwards -- it's an easy test to try -- it will either work or not!

Also, make sure the pins are fully seated and didn't back out when you installed the wedgelock.

There are a few things I just wanted to confirm in regards to the bus, and a few other items i want you to fix up.

- How long is the CAN bus?

- CAN you please double check from the UTC to the AEM that can Hi is going to Hi, and Lo to Lo

- Are the CAN bus wires twisted together?

Now, re looking at you AEM config, you need to change from set 3 to set 1. They are two separate templates, and nothing from set 3 will line up.

If you have 0x0E8 set in the AEM, then you need 232 set as your address for the M84.

Also I noticed they have an import button in the dash software? What format does it take? .DBC? if so, I will see if I can dig up an M84 .dbc file for you

Attached Files

Hi David,

No luck yet. I first reversed the pins as you suggested at the AEM 12 pin connector without success.

The way the car is currently wired is M84-->UTC Connector-->4-pin DTM connector-->AEM Dash harness-->DASH.

Tonight I tried eliminating the AEM DASH harness and built my own. That did not work either. Tomorrow I will go straight from AEM Dash to M84 and bypass the UTC connector as the backside pins are not easily accessible. That will eliminate the last remaining part of wiring in case there is a solder joint issue with the pins on the backside of the UTC connector.

Hi Nathan,

Looks like you posted as I made my last reply and I didn't catch your reply.

- The Can Bus I don't think is very long. It goes from the passenger floor foot area to the driver dash/cluster. If I was to estimate about 800mm.

- I did double check and even flipped the wires as David suggested to see if that would work. No success.

- The AEM instructions (attached) say to use Data Set 3. Regardless I will try that shortly. When I do click Data Set 1, it changes the ID to 0x5F0.

- My M84 address is indeed set to 232.

- I've attached a screenshot of the import button. Looks like it is DBC. If you can do that, I would greatly appreciate it.

Attached Files

We usually reply within 12hrs (often sooner)

Need Help?

Need help choosing a course?

Experiencing website difficulties?

Or need to contact us for any other reason?