×

Sale ends todayGet 30% off any course (excluding packages)

Ends in --- --- ---

urgent: link can keypad and aem dash not working on Link FuryX

CANBus Communications Decoded

Forum Posts

Courses

Blog

Tech Articles

Discussion and questions related to the course CAN Bus Communications Decoded

= Resolved threads

Author
286 Views

I have been struggling for days to get the ecu to connect to the link keypad and aem dash. my can bus is on CAN 2. i check can high and low and all are correct, I measured the resistance from one of the aux can connectors when the dash and ecu only were connected and the resistance was 60 ohms. when I plugged in the keypad, the resistance dropped to zero. two tuners have tried to get the to work however one of them said that there's a conflct between the dash and keypad somehow resulting in the ecu not connecting to them. I have taken it upon myself to resolve this issue since I am the one who did the wiring for the car and is getting blamed for the entire issue. Please guide me through this issue and if someone has a video of how to setip a can keypad on link ecu and how to setup aem cd5 dash as well, please share it with me as I have less than 8 hours to figure this out. I can't figure out what the problem is

Double check your wiring to the CAN keypad, since it's the one that stops things from working. It's easy to get pin numbers mixed up, or have a layout for the front of the connector (contact side), when you are looking at the rear (wire side). Is the CAN bus speed (aka CAN Baud Rate) correct for all devices?

verify the bitrates are correct. 500k :: 1Mb issue is presumed

Did you get this sorted? Sorry I dont visit here often, for future reference you will get quicker help on the Link forum or by contacting tech support directly.

If you still need help then attach your ecu and dash configs and I will take a look.

Your resistance measurement sounds suspect as the terminating resistor inside the ecu is open circuit when the ecu is off so you should only have 120ohm when measuring the bus resistance. Although I doubt that is relevant to your problem, it may indicate a wiring issue.

Hopefully this is resolved, but let us know. We'd love to help.

I’m am having the same problem with the cd5 with the s300 hondata v3 I followed the Aem dash setup and wire the two wire for can high and can low to the can2 put the power and ground uploaded the dash all my inputs are correct but I’m still not getting a response my dash works but non of my gauges are working

We usually reply within 12hrs (often sooner)

Need Help?

Need help choosing a course?

Experiencing website difficulties?

Or need to contact us for any other reason?