Forum » EFI Tuning Fundamentals » PID tuning for E-throttle

PID tuning for E-throttle

EFI Tuning Fundamentals

Forum Posts

Courses

Blog

Tech Articles

Discussion and questions related to the course EFI Tuning Fundamentals

= Resolved threads

Page 1
Author
214 Views

Hey guys, So I just installed a Bosch 82mm Throttle body 0 280 750 473 and Ve commodore pedal (Link G4+ Fury)

I am having issues getting the TB to work correctly I think the PID settings for it are incorrect, so I emailed link they came back with this (see attachment below). I was wondering how do I tune the PID settings? I haven't tried those settings yet as I am at work (I will tonight) but I have used settings close to that and calibrated the TB successfully but then when I give it a constant % of the acceleration the throttle blade goes wild and flaps about. I have no wiring errors, I think it's just the PID settings. (also for reference the E-throttle 1 target table I setup) that's another question, what is the ideal e-throttle target table?

Thank you!

Attached Files

Hello

The PID settings from link will be bang on to understand the pid setup press f1 in while looking at any part of the DBW set up this will give you the full explanation or jump into our webinar on DBW

Nah, link said: the following should be an ok starting point to then tune them from.

just thinking about the banging have you checked after the auto set up that the throttle plate is going the correct direction ? and did you read the help file in f1

What do you mean the correct direction? Can't they only go one way?

Yeah I've tried the help

when you put your foot down is it trying to open the throttle plate or close it you need to actually watch it dont take it for granted

have you emailed your map and log to tech@linkecu.com ?

Yeah it opens fully up, it opens gradually as I press the pedal, but it flops around (I have a video but it won't let me upload it)

Hey guys, so I fixed the PID settings (tuned it till it works) NOW I'm having an issue where the ethrottle works perfectly (I've already calibrated it etc) in ethrottle on setup mode, but when I change it back to ethrottle 'on' it kills the aux 9/10 relay (e throttle +&-) and the throttle doesn't work. Got any ideas? Gives me fault code 73: aux 9/10 supply error.