×

Sale ends todayGet 30% off any course (excluding packages)

Ends in --- --- ---

Rb25det s2 issues

General Engine Building Discussion

Forum Posts

Courses

Blog

Tech Articles

Talk about engine building here. New products, tricky questions or showcase your work - If it's engine building related it's welcome here.

= Resolved threads

Author
299 Views

Recently replaced my engine harness after old one fried. Also replaced spark plugs, cas, coils, and tps sensor. Car runs and drives but bucks hard on take off and acts like fuel is being cut on both stock and haltech on ecus. Unplugging tps, she runs ok except a little sluggish on take off. But has to be revealed to at least 4k if tps is plugged in to keep the jumping from happening. Tested maf, works fine, all plugs firing no issues. Checked for boost leak and couldn't find one. So I'm getting low on options. Trying not to pull intake to get tobinjectors if possible, but any ideas would be helpful. Thanks in advance.

When the old harness "fried", could it have taken out the TPS, and have you double checked the TPS is correctly wired and of the correct type? I assume all the hardware, other than the actual harness, is the same?

I replaced it with a new one thinking it was bad. Also replaced plugs, coil pack, cas, and o2. Still not working right. Cleaned maf sensor and tried using map instead on haltech with wideband o2, still dose it. At a complete loss.

Ken,

I'm sorry this has been a struggle. When you say the harness fried, if multiple wires were damaged or shorted together, the possibility of multiple sensors or electronics being damaged is present. Testing each sensor, circuit, device one by one is tedious, but is sometimes required to find all the pieces impacted by the wiring issue. Sometimes you get lucky and find a faulty piece right away, sometimes it takes a bit of time.

From the engine behavior, it sounds like you aren't injecting enough fuel, so I'd also confirm fuel level and fuel pressure just in case.

If you have access to a haltech ECU that fits your car as you said, you can make a log of various sensor parameters during a drive (while trying to reproduce the problem) and check if the data was how it should be. Of course, having extra sensors like a wideband and a fuel pressure sensor wired in the ECU would definitely help diagnose the problem.

If you want to post the log, I'd be more than happy to take a look and help!

Haltech doesn't record for some reason. It says it is, but then when you stop, the data just vanishes. As for the issue, it bucks or if clutchbis in it will have no response when depressing the throttle for a fee seconds then it will just rev up if tps is plugged in. It's very odd.

As for sensors, replaced cas, coils, plugs, tps, and both knock sensors. Replaced harness with new wiring specialties, with five point grounding harness. As stated if tps is plugged up it bucks in gear till I get around 3500 rims in first and second, but if it is in neutral it sometimes doesn't respond to throttle for a fee seconds. If I unplug tps, idle drops about 200 rpms, but responds a bit sluggish for a second or so on take off, but the drives completely normal. Maf has no effect on idle, but boggs heavily when unplugged under load. If tps is plugged and maf not, it bucks worse then and I get fuel cuts heavily. As soon as tps is unplugged and maf is plugged in it runs fairly normal except being a slight sluggish in take off. Can't locate boost leaks anywhere, every thing is hooked up properly, only things I can come up with are either cas is off a bit, or injectors are not receiving signal to open but only when tps is plugged in. Makes no sense.

We usually reply within 12hrs (often sooner)

Need Help?

Need help choosing a course?

Experiencing website difficulties?

Or need to contact us for any other reason?