×

Sale ends todayGet 30% off any course (excluding packages)

Ends in --- --- ---

Haltech elite 2500

General Tuning Discussion

Forum Posts

Courses

Blog

Tech Articles

Discuss all things tuning in this section. News, products, problems and results. 

= Resolved threads

Author
476 Views

a friend of mine has 200zr with a 71v teanny. He is not getting signal from the speedo to the cluster and asked me if it needs to be calibrated or configured on the elite 2500 series haltech system. I could not find anything on this so thought I would check here

Thanks

Depends entirely on how he has the Elite and stock tach set up. The Elite certainly can be configured to output whatever signal the stock cluster wants RE: pulses and total sweep if the I/O is setup properly.

Your question is not completely clear, but a 200ZR has a cable driven speedo doesnt it?

Not quite sure how he has it as he swapped to the rb26 engine. I do know the tach is working just fine, and according the wiring shop he used for the engine harness everything should be wired correctly. Speed meter just doesn't respond

Not quite sure how he has it as he swapped to the rb26 engine. I do know the tach is working just fine, and according the wiring shop he used for the engine harness everything should be wired correctly. Speed meter just doesn't respond

I'm an idiot, I read tacho not speedo. Regardless it should be doable and depends on far too many variables to give an answer than the info given. Apologies.

Cool, think I figured it out though. Thanks for the quick replies guys