Forum » General Tuning Discussion » Need help tuning a cough and sputter

Need help tuning a cough and sputter

General Tuning Discussion

Discuss all things tuning in this section. News, products, problems and results. 


Page 1
Author
151 Views

Hi guys im Harley Davidson Master tech and dynojet tech

ive got a 2016 Harley Low rider S

its a 1800cc motor

upgraded the throttle body from 50mm to 58 mm its flybywire

increased injecter size from 3.91 gms to 5.3 gms

upgrade cam to one with lots more lift and duration

using a powervision tuner which is a dyno get product so uses Win PV software which im familiar with

bike cruises great except

on the road in 3 to 6 gear at at 2000rpm if i give it full throttle with the fly by wire set to 1:1 (so no slower movement at lower rpm) the bike goes into a cough and splutter and wont rev out of it until i go to less throttle.

AFR at this point is a bit of false data said it was rich at the even so leaned it out this made it worst enriched it in the area no change. reduced and added timing no change i slowed the fly by wire down so it only goes to 100% throttle after 3000rpm in the stock increments coughed a little but gets out of it slowed the throttle down a bit more and it works 99% of the time no worries.

ive checked for intake leaks faulty sensors everything mechanical checks out

this is also not the first one of these ive heard of it doing it

please any ideas would be much apprieciated

cheers calum

Plugs ok?

How is the accel enrichment at that point . To much will cause a rich cough/missfire . If you wind throttle on smoothly does the engine rev through this range with no problem ? And how does the AFR look as you are doing it ? This could give you a clue if the problem is accel enrichment related .

If it's tip in fuel, lock the dyno to a fixed rpm and do fast tip ins and see if adjusting tip in fuel helps.

I've seen that exact issue with a broken throttle position sensor, basically the customer was at WOT but the throttle position sensor trace in the log file showed up and downs as if he was tipping in and out on the pedal.

One tip is, to log the TPS value with a pretty high frequency, otherwise the ECU would interpolate and smooth out the trace in the log.

Also, you can add the accel enrichment parameters to your logging, to give you a better indication if it's accel enrichment related (or TPS for that matter).

Thanks guys. Tp sensor is working correctly

I have leaned off and enriched the fuel enrichment with no change

If i slow down the throttle movement it fixes and thats why i slowed the fly by wire down cheera

Thanks guys. Tp sensor is working correctly

I have leaned off and enriched the fuel enrichment with no change

If i slow down the throttle movement it fixes and thats why i slowed the fly by wire down cheera

All i can add is that if you accelerate slowly through the rev range will no issues - Then if as you say you give it wide open throttle at low(ish) revs the map must be accessing rich cells in the fuel map under high load and low revs - i hope im not stating the obvious - sometimes it can spark a thought in the right direction - i hope :)

Thanks mate all input is helpful