Sale ends todayGet 30% off any course (excluding packages)

Ends in --- --- ---

RX7 FD S7 - Very strange Trigger Problem

General Tuning Discussion

Forum Posts



Tech Articles

Discuss all things tuning in this section. News, products, problems and results. 

= Resolved threads



I've got the following problem on a RX7 S7 with adaptronic modular plug-in ECU.

The car is running fine, until it reaches 5000 to 6000 RPMs. Here trigger errors are happening.

On the Attached image 'good.png' you see the triggering when the car is running well.

On the next picutere, 'signal_loss.png', you can see that CAS1 and CAS2 are completly flat-lining when the engine reaches 5000 rpm.

If I'm right, on a conventionel trigger-error, when the VR sensor signal is not in the trigger range, I should also see a signal on the ECU-Scope.

But there isn't even noise in the scope, just a flat line.

For me it looks like a dead ECU.

Trigger and ignititon hardware is bone Stock. Car was running a adaptronic select before, with No problems.

Do you have any ideas?

best regards


Attached Files

Also very interesting how all the values that the ecu shows go wild, as you can see on the attached screenshot. This only happens on higher RPMs at the same time as the trigger errors.

Attached Files

G'day Bastian.

Can you post up any log of scope files from the ECU? I'll have a look at them in the software, will give a better indication then just pictures.

My first thought is a physical wiring harness problem though. Does the problem always happen at the exact same RPM level, or does it move around a bit? Does it only do it under load, or during a free-rev too?

Hello Zac,

thanks for you reply. Just one information on the history of that car. It run a adaptronic select plugin before with no problems, I just changed the ECU to a modular plug in.

To your question: Its happening always around 5700 RPM, where ECU starts to see wrong data, like negative RPM, internal CPU Temperature with 1600 Degree Celsius or even a wrong calculated AFR like 162:1 (serial input, not analog). It happens under load and on free rev too. I think it's a dead unit because a wiring problem on the harness would not affect internal data inside the CPU like cpu voltage and cpu temperature)

The Scope file and CVS format are attached.(scope is zipped because the filetype ist not allowed here) In the scope file have a look at about 38,8 Seconds, you can see the weird data in the f11 windows then.

Thank you!

Attached Files

I talked with adaptronic support and they told me to check my ignition leads.

They were new leads from Bremi, but have the wrong resistance. 1 kOhm instead of 6 kOhm, so I switched back to the old NGKs and now the problem is a bit better, but it's still a problem.. :/

And I'm also veeeery suprised that the adaptronic is so sensitive to electromagnetic interference...

The ECUs now doesn't seem to crash completly, now there are just two problems.

The first problem. CAS 1 is sometimes very noisy, but just under load now. (screenshot and logs attached)

This causes trigger errros

CAS 2 has two spikes on higher RPM, but it's no problem the filters are doing well.

The second problem. Sensor Ground Voltage has sometimes 0.008 Volts which is very good, but sometimes it has 2.8 Volts, for no reason.

I'm still thinking it's a bad unit

Attached Files

G'day Bastian. Sorry I left this hanging, I was sure I replied to you yesterday, but apparently not.

Bit of a limited selection for rotaries, but what sparkplugs are you running?

Have you got access to an external oscilloscope at all, not the one within the adaptronic ecu?

I've tried to have a look at your scope files, but I can't for the life of me figure out how to open them in Eugene...!?

Hi Zac,

to replay the scope files, you need the newest version. Mine is 1.98 . In the scope window under diagnostics, there's a tiny checkbox "Playback" under the scope. (attached screenshot)

I'm using NGK BUR9EQP. I think that should be OK because they are "R" Plugs.

thank you :-)

Attached Files

Yeap, plugs should be fine.

Cheers for the hot tip on the scope playback. I was able to have a quick look at your trigger signal scope, and your sync signal is pretty messed up at the upper RPM range by the look of things. It rises up as expected, shoots negative, has the rest of the hump, shoots positive, then falls back to zero as the tooth move away from the sensor.

I can see the sections of a heap of noise too, but cant isolate them, as I cant scroll through the scope playback it would seem.

I'm still leaning towards a wiring harness issue, is it the original harness in the car?

Attached Files

Yes Zac, the Harness is the OEM one, with OEM coils, and resistor ignition leads and plugs.

But i found some bad grounding points on the engine. Maybe they cause this problem. I will repair it and make a new log.



Looking forward to hearing how you go Bastian.

Not exactly the same as your problem, but in our Fueltech we had such massive errors that we have lost the rpm signal when we went closer with a mobile phone to film it. Sounds strange but it happend.

A check of the ground connections solved the problem. In our case it is mandatory to wire the ground exactly like Fueltech says ( 3 wires to the engine and 1 directly to battery negative ). It has had a strong effect for us.

Any updates ?

Hey! Sorry for my late answer.

The problem is solved and it was really just a little thing ;)

It was the grounding from the engine. That OEM grounding is so bad..

You can see it on the picuteres.

Thanks for your help!

Today after one day without Problems it's happening again. Tomorrow I will Change the adaptronic to a new one and will report.



in the attachment can you see how looks now..

Attached Files

Wow, that's nasty. I'd still be looking for grounding issues. Can you run some temporary ground wires from the ECU power grounds to the chassis, and double (triple and quadruple) check the ground from the engine to the chassis, and chassis to battery?

If you can be sure you battery power is up to it, it might be worth trying a run with the alternator disconnected, to see if that's a source of noise too.

Hi Zac! You can see my new grounding in the attachment, next to the first grounding wire in image one, is the ECU grounding wire.

Unfortunatly I can't test my new adaptronic because german customs has it for a examination... maybe I can do it end of the week

Attached Files

Your OEM EFI wiring harness will have two ring terminals that connect to the engine block also, can you check they're securely attached and making good contact?

Hi I'd wait to see what the new ecu is like, there's quite a few people running adaptronic on Rx7's over here in the the UK and most of them having problems some having 2 or 3 new ecus sent out due to faults on them most selling up and moving to different ecus as a result of endless problems.

Hi Mattin, I heard the same from a other person from netherlands. He said that he doesn't know anyone that has a unit that worked from the beginning. They all got a replacement.

I also had a broken unit on a different car(S6 RX7)

Tomorrow i will test the new unit. Today I got the replacement

Hi guys,

This is Mark from Adaptronic just chiming in. I'm talking to Bastian directly about it as well, and we're at the point that we'd like to see if it's ECU related or not, so we've sent him a new board to test. The current one that Bastian has, is one of the early ones. To be honest, we did have some issues with some of the early units where in they showed the issues on the field. All the units are hardware-tested prior to sending, so they wouldn't be sent out if they showed faults outright.

I may not be here always to reply but if anyone has questions please feel free to shoot us an email at tech@adaptronic.com.au



So the new board is installed but still almost the same problems.

High revs and the ECU resets,

Just the scope view doenst looks so weird as the last times:(image attached)

I would like to point out once again that I only changed from select to modular, otherwise nothing was changed! With adaptronic select there were no problems... unfortunately I don't have it anymore.

Attached Files

This is also strange with the new ECU. cas 1 is now without Problems but cas 2 often misses one side of the Amplitude(attachment)

Attached Files

Maybewith the new screenshots someone can help me:

On the first screenshot(immediatily before the error happens) you can see that that the Amplitude gets cut off on the positive part, and it gets added to the negative part.

After that the trigger error happens with very much noise.

Attached Files

The differential of your signal remains the same, which leads me to think you've still got currents flowing where they shouldn't be, causing the voltage offsets you're seeing. Have a read of this: https://www.hpacademy.com/technical-articles/staying-grounded/ to see what I mean.

Possible to get a scope trace of just the sync signal trace, over a longer time period? I want to see if there is any regularity to the voltage offset issue you're seeing.

We usually reply within 12hrs (often sooner)

Need Help?

Need help choosing a course?

Experiencing website difficulties?

Or need to contact us for any other reason?