Forum » General Tuning Discussion » RX7 FD S7 - Very strange Trigger Problem

RX7 FD S7 - Very strange Trigger Problem

General Tuning Discussion

Discuss all things tuning in this section. News, products, problems and results. 


Page 1 , 2
Author
1348 Views

Hi Zac,

I'm going to make a longer scope trace for you, but if you want to only see the sync signal, you can just untick the other signals on the lower left corner. Only tick CAS2 as visible.

Tomorrow my portable oszilloscope DSO302 will arrive, and will also make a scope trace with this separate scope. I'm also going to change the pickup sensors, because I have the feeling that the problem gets more present when engine is hot.

Thanks for the link :-)

So Zac... i decided to check my harness after your great post, and after inspecting it I found a big mess done by a pre-owner. I will rebuild it and post the result

It does seem like FD's suffer from a lot of 'previous owner' problems. Hit me up if you'd like some good info on the S7 wiring harness. I've completely toned mine out, and have 95% of the required connectors and pins identified to build another.

Hopefully you get it sorted soon Bastian. It sounded more and more like loom bugs looking at your progress.

Zac, while you are talking rx7 loom bits I might pick your brain and ask about the wiring course progress/content. I am trying to stick with the apexi ecu i have in my s8 and just add a few bits and pieces to allow high power with ancillary component operation on single turbo water injection. I have a billet coil kit with r35 COP but the sub harness is set up for 3 channel. I want to make a new sub loom and drop back to just the trailing channels so I can run more dwell (leading and trailing on each rotor on the same channel). I have already bought an ecu loom extension so that I can wire in my plex combustion logger without chopping things up. I will need to buy new connectors/pins/wiring for the ignition sub loom and buy a deutsch/round pin crimper for additional wiring of water injection level sensors/control and the plex "mil spec" round connectors. (I already have the crimp/pin tool set that Haltech sell for blade type connectors, and the plastic pin install remove for the round pins on the plex logger).

I'm happy to sign up for the electrical content first if you prefer but if you have plug part listing for the ignition and the solenoid control and/or pin outs in English as only the earlier stuff seems to be common. My intention is to run an optical level switch to drive a positive side relay to intercept power to boost/turbo control solenoids pwm/switched earthed by the factory loom and a hobbs switch to trigger pre-turbo water injection with the level switch dropping wastegate control if low and the factory loom secondary control switching triggering a smaller secondary water injector.

So this is what my harness looks like, I'm a bit confused that this should be OEM. I never seen such a bad work from a OEM how it is isolated.

To FD owners: can you confirm that this is normal and how it should look?

Attached Files

Bastian. I actually live about 450k's away from HPA Labs, and commute down here for the week to work. I'll have a look when I'm back home on Friday and get some pics up for you.

Michael - I'll start a new topic in the wiring section of the forum about your questions to we don't clutter up Bastians thread :-).

Bastian, that looks OEM from what I've seen in the past. Crimps are usually OK, but their isolating tape job was messy as hell.

Had a look at the trigger / ground wiring from my OEM harness, and I would agree, it looks factory.

Have you had any luck with the other ECU Adaptronic were sending out?

Attached Files

The new ECU didnt Changed anything. But I was not lazy, I have installed a new harness, Made all grounding Points new and installed new high tension leads. I will Test it the next days.

Also interestInt, this ist what andy of adaptronic Said:

It’s ignition noise. Clear as day!If you look at scope pic #3, you can see the spikes on both CAS1 and CAS2 waveforms.The zero crossing for CAS2 happens at about 15 degrees BTDC. You remember in the log that the leading plugs fire at about 20 degrees BTDC at 5500 RPM, so the noise on the CAS line happens coincident with the leading ignition. It looks to me like the glitch on CAS2 happens with rotor 2 trailing ignition.It could be a bunch of things:1) Ground loop on sensor ground2) Poor shielding on CAS3) Incorrect grounding on CAS (if the loom has been hacked or damaged)4) Lack of grounding on the ignition coil cable (that goes from the ignitor to the ignition coils, it’s a shielded cable, if that shield isn’t grounded then you’ll get problems5) Faulty capacitor (condenser) on the factory ignitor6) Poor engine-to-body groundIf it were me I’d check all the sensor grounding and the cables, and then replace the ignition system with a 4 smart coil system and do the grounds of all the coils to the keg / rotor housing (or the centre iron).It’s pretty clearly ignition noise but I don’t know what in the car is causing it. It’s so big, it’s tens of volts, normally you just don’t see ignition noise this big so it’s going to be a big problem, not a marginal one.

I'm back and f***** frustrated.

I changed the whole harness, I remove the ignition System from Mazda and replaced it with 4 AEM smart Coils. But the proble is still there.

So for me it is clear as day, that the ECU is the Problem.

Update, the Error only appears when the ECU is conmecred to a Laptop. Tried different Laptops and different USB Cables.

Without connected ECU it's good.

I asked adaptronic for a refund. I dont trust the Hardware anymore.

Did you have your laptop plugged into an in car charger at all?

That it really, really, weird, but I hope you've found a solution to the problem. We'll be doing a worked example of an Adaptronic in a rotary application in the future, so keep an eye out for that to see how we get on.

No, laptop is running with his own battery. I also tried two different laptops.

I checked the CAS signals with a external scope and the signal is crisp with no noise on it