Forum » General Tuning Discussion » Twin scroll turbo tuning strategies

Twin scroll turbo tuning strategies

General Tuning Discussion

Discuss all things tuning in this section. News, products, problems and results. 


Page 1
Author
460 Views

Hey guys, we just received a sti with tomioka 20g billet twin scroll, the tuning strategy is similar to a normal turbo? We teste with the same tune the previous turbo had but only achieved 15 psi at 3rd gear, also at 90% wgdc, this seems odd..

Are you using a twin scroll manifold?

I've never done anything different with my boost control strategies from single scroll to twin scroll.

What waste gate are you using?

It has a twin scroll manifold from tomioka, also the wastegate is internal .

Are you running the stock solenoid or a 3port?

Twin Scrolls can be tricky especially if not setup correctly.

Check your basics first like actuator itself is setup correctly and you have appropriate amount of preload.

We are runing 3 port solenoid (grimmspeed), k&n high flow filter.

I've never adjusted my tuning strategy between single scroll and twin scroll. Go over your basics and ensure the wastegate is closing properly and you have no boost leaks. I trick I use to eliminate any possible issues with electronic control is to disconnect the vacuum line from the wastegate temporarily and try and pull on the dyno. You need to do this with care and always make sure you have a boost cutout set up first as it can (and should) result in massive over boost. If the boost goes above 15 psi then your problem is with your boost control system. If you still get 15 psi then it would most likely be a mechanical issue.

Our dyno suffered major problems so until next week there is not much we can do, but yesterday I was able to do sum runs on 2nd gear with 90 wgdc and 0 wgdc and we have the same psi 15. But at 30 wgdc we reache 17.8 so I having a hard time understanding what might be wrong. I preloaded the wastegate actuator to raise psi required.

Any other ideas on how to diagnose, i will try to run without vacuum line to wastegate actuator.

Our dyno suffered major problems so until next week there is not much we can do, but yesterday I was able to do sum runs on 2nd gear with 90 wgdc and 0 wgdc and we have the same psi 15. But at 30 wgdc we reache 17.8 so I having a hard time understanding what might be wrong. I preloaded the wastegate actuator to raise psi required.

Any other ideas on how to diagnose, i will try to run without vacuum line to wastegate actuator.