Forum » General Tuning Discussion » VDO speedometer not reading signal

VDO speedometer not reading signal

General Tuning Discussion

Discuss all things tuning in this section. News, products, problems and results. 


Page 1
Author
83 Views

Ive bought a vdo programmable speedometer and I can't get it to read either an induction signal or a 2 wire hall effect. Ive tried running the hall effect though a gm relay 09.185.826 as someone has said thats what I need but still no luck. Anyone had any issues like this before? The person ive spoke to thats got it working through the relay has 2 inputs into his speedo pins 7 & 8 but there's only 1 output from the relay so I'm lost.

Attached Files

What engine and what ignition system setup?

Engine is an m52tu but its in my tube chassis pickup. Its running BMW suspension all round. Its running the standard ignition. I believe originally the abs sensors are fed into the abs unit which turns it into a canbus signal for the dash.

Many BMW ABS sensors are active sensors, you will need some external conditioning to make it compatible with your speedo. [url=https://www.motec.com.au/filedownload.php/CTN0007%20Magneto%20Resistive%20Sensors.pdf?docid=3634]https://www.motec.com.au/filedownload.php/CTN0007%20Magneto%20Resistive%20Sensors.pdf?docid=3634

sorry, this forum software has messed up the web address. Search Motec site for ctn0007.

I was told that the gm relay was a wave conditioner and would turn it to a pulse signal but it didnt seem to work do they have to be wired the right way round?

I was told that the gm relay was a wave conditioner and would turn it to a pulse signal but it didnt seem to work do they have to be wired the right way round?