Sale ends todayGet 30% off any course (excluding packages)

Ends in --- --- ---

DBW tracking error

MoTeC M1 Software Tutorial

Forum Posts



Tech Articles

Discussion and questions related to the course MoTeC M1 Software Tutorial

= Resolved threads



I am having an issue with my dbw setup with the M130. I have watch the tutorial and did pretty much what I can think of so any help is appreciated.

Basicly, my pedal sensors are working perfectly, my Throttle servo position sensors are working perfectly but when I turn on the bridge output the throttle will work for a second and then I have an AIM TRACKING FAULT showing up and plate goes back to closed position. All my tables are setup linear and goes from 0 to 100.

I tried to use only one sensor instead of using both tracking but it still does the same thing.

When I move the throttle by hand both sensors have almost the same angle and no diagnostic faults is shown. Same for pedal position.

thank you


I am using the Jenvey actuator and it seems motec already has the setup data available for it. Here is the link.


I still have the same issue with it. Full WOT it will reach with no diagnostic errors but the blade is moving a lot. With 80% opening, the blade will oscillate a lot around the target with still no aim tracking error. The lower the aim target I go, the more the actuator oscillates.

Low aim target, forget it, it will open and and goes back to closed postion with the aim tracking error.

I have played with the setting for 3 hours now and starting to believe that the actuator just doesn't run properly with the M130.

Motec support has been pretty much as usual: "contact your motec dealer regarding any issues you have"

Thanks for you support.

You just need to keep working on it. I would not be surprised to spend 20 hours (over several days) tuning a DBW throttle body. There are lots of knobs in the M1, you need to make sure the tags have been ticked to show you setup, tune and advanced items. Log various channels at high sample rates to see how closed loop PID system is responding. Try different frequencies. Work with your dealer. That is what they should help you with.

Hello David,

Well thank you for your response. It is much appreciated. I certainly didn't expected to spend so much time to make it work. Unfortunately I will have to do it another time since the car needs to be running in two days and still need to properly tune the car.

thanks for your help and I will update the post when I am back at it.

No more issues with it. Had an issue with wiring. Seems to be working pretty good with the specs from the sheet.


So I can learn -- what was the wiring issue that caused that behavior?

Hello David,

One side of the actuator was connected to ground. I was surprise the motec was even able to move it. Did not look at the wiring at first but we had the engine out of the car so I decided to take a look at the harness at the same time.

Thank you for following up. I appreciate that.

We usually reply within 12hrs (often sooner)

Need Help?

Need help choosing a course?

Experiencing website difficulties?

Or need to contact us for any other reason?