Sale ends todayGet 30% off any course (excluding packages)

Ends in --- --- ---

Debugging connection issues during cranking

Practical Motorsport Wiring - Club Level

Forum Posts



Tech Articles

Discussion and questions related to the course Practical Motorsport Wiring - Club Level

= Resolved threads


Hi folks, I just finished the club level course and my first harness for my '90 Miata. I'm using an MSEL Master Relay with an AiM PDM32 and a MegaSquirt MS3X ECU. I made some mistakes during the harness constructions, mainly a couple sections of the main trunk were too long, since I was to be too conservative with my measurements and as a result the fit in the car wasn't amazing. But overall, I was satisfied with the results, specially considering that when I installed the harness everything just worked.

However, after I successfully started the car a handful of times, it no longer starts. I can turn on the kill switch and ignition switch, and test all the outputs (lights, fuel pump, etc) and everything works fine, but when I crank the car I've seen two errors on the MSEL: overcurrent and "power on reset". My first thoughts are that the issue comes from the car shaking during cranking, perhaps too much stress on some section of the harness. The power on reset is specially telling, since it indicates that power was taken away from the device temporarily and then restored. Considering how close the MSEL is to the battery (see the photo attached), my only suspicion is that there is a bad connections in the MSEL ground path, which includes 3 crimps: the pin and socket for the DTM connector and the ring terminal. I don't see how this wouldn't explain a true overcurrent, but I figured I might as well start by addressing this. I tried moving the harness around to see if I could reproduce the issue, but nothing worked. My next step is going to be measuring the resistance between the MSEL connector ground pin and the ring terminal, but I figured I'd post here to see anyone had any insights on how to go about debugging an issue like this.

Thanks in advance

Attached Files

Often the battery will become discharged from being on while testing / configuring. Be sure to use an external battery charger to charge the battery if you have having voltage drops and resets during cranking. I usually put a small 4A charger on when I'm working on a car so that the battery will be ready to start the car when I am.

I would check the battery voltage and if it's not 12.7 or higher prior to cranking, I would charge it. You might want to observe what the battery voltage drops to while cranking. Cars that go below 10.5 volts seldom want to start even though they are cranking.

That's a good point, it did cross my mind before, but the battery was reading 12.0V in the dash and I thought that would be enough. Might be worth noting that I'm using a Battery Tender lightweight battery (this one). Could the battery not being fully charged cause it to shut down the kill switch? Because it's not even cranking slow, it'll crank for ~1s, sounds normal, and then the kill switch shuts everything off. In any case I'll charge the battery before trying anything else, thanks!

As the voltage drops, the current required by the starter motor goes up. Your solid-state switch may be seeing too much current so shuts it down.

Using the 680-sized battery, I would normally always have a jump battery attached if planning to start the car several times without necessarily running it enough to re-charge the battery.

Good Luck!

That does make sense, but given that I have a 1kW starter and the switch is rated for 200A, so the voltage would have to drop below 5v, that seems unlikely no?

Nevertheless, I'm charging both batteries to test it, but while I wait I checked a couple things:

- The battery was barely discharged, when I plugged in the charger indicated that it was >=80% charged.

- I should have checked the voltage at the battery, apparently the AiM dash shows a lower voltage (after charging I'm seeing 13.1 in the battery and ECU vs 12.2 in the dash). I asked and apparently this is common.

- The resistance between the MSEL ground pin and the battery negative is 0.5Ω, moving the harness doesn't show any signs of a bad connection.

I'm mostly stumped by the power on reset error on the switch, could that also be caused by low voltage?

Start a topic with MSEL switch in the title, I'm pretty sure Richard Moss from MSEL participates in this forum and perhaps he will see it.

To simplify things I removed the MSEL from the picture while debugging, just using a circuit breaker for now. The car now starts, but runs very poorly. I noticed AFR was reading 7.5, but what appears to be happening is that the wideband sensor is being restarted while the car is cranking. I measured the resistance between the wideband sensor ground pin the chassis and it reads less than 1Ω, but when I crank it goes up to ~500Ω. Is there anything that could cause this other than a bad crimp/connection in the ground path? At this point I'm considering just throwing away this harness and starting from scratch.

A wideband sensor resetting during startup will not effect how the engine runs, even if closed loop is enabled full time there will be start-up and engine temperature lockouts, and generally some sort of default value so that if a sensor fails or disconnects the engine still runs in a safe manner.

Your resistance measurement is invalid, you cant measure resistance of a conductor when there is current flowing across the conductor.

Sorry, I think it wasn't clear from my last message, but I measured the resistance using the ground pin that usually connects to the O2 sensor, but the sensor was disconnected. Although there was still current flowing through one part of the path I guess. As for the engine running poorly, I noticed the MAP sensor is showing 94~95kPa throughout the log, so maybe that'd do it? I attached the tune and log if anyone is interested.

I found at least one issue so far while doing a once over everything: I'm using radlok connectors, and 2 of the ground connectors didn't pass a tug test. I did test it before installation, so I'll have to look into what happened, but I obviously didn't pull it with enough strength while testing. I'm using this crimper for the radlok connectors, should I be using something else?

I'm hoping that is the only issue and that I haven't fried anything

Attached Files

Those hydraulic crimpers should do a tubular radlok fine, I have something similar. Don't always rely on the size stamped on the die though, they obviously weren't designed for that specific terminal so the marked die size may not be relevant. There are crimp heights and widths specified in the radlok datasheet.

Definitely unlikely to run well with the MAP sensor not working.

Perhaps the MAP sensor is measuring a vacuum leak (did you disconnect the fuel pressure regulator ref hose to set the fuel pressure?)

The harness is off the car, but I looked over everything and nothing jumped out at me. I didn't disconnect the fuel pressure regulator, but I have disconnected other vacuum lines, but they seem to be all back in place now. Would a vacuum leak be enough to read at 94kPa? I also saw suggestions that I could be using a bad vacuum source in the manifold maybe? Either way I'll pull the ECU off the car and bench test the MAP sensor since I have to wait a couple days for the replacement radlok connectors to arrive anyway since I didn't have any spares.

If the hole that is left open is large enough, you can read ambient.

I found the issue with the MAP: while working on the car I unplugged the hose and plugged it back on a different port, which happened to be closed. The car is now runs better, but still won't idle, but that's an issue for a different thread.

As for the cranking issues though, I replace the poorly crimped battery cables (the new crimps are also terrible, but I pulled on it as hard as I could and I'm sure its solid, I got replacements and will do it once again later), but the wideband is starting restarting when cranking and sometimes the PDM shuts off. I'm having trouble getting the PDM to log, but from glancing at the lights it looks like might be low voltage... This was with 2 batteries, so not sure what to try next.

I would contact Aim through your dealer. The PDM has escaped, not really been released since the software is still Beta.

Firmware guys in Italy would want to know about this, and might be able to fix it....

Is your PDM driving the starter solenoid? Is it on a high-current output?

The PDM is driving the solenoid through its dedicated high current output (#1). I did manage to trigger a log through Race Studio, but it stopped on its own after 15s...

This thread is getting embarrassing for me, but I'll document things honestly: the extra battery wasn't actually connected... I was using a cable that came with the Battery Tender battery to connect my old battery to it, but the cable was only meant to charge it and had an inline 7.5A fuse. Obviously the fuse blew out when I cranked the car

Did you ever solve the issue with the MSEL tripping over current protection?

I'm currently in the exact same boat. Currently successfully started my car, ran for 15 seconds, and then I shut if off. Now the overcurrent protection on the MSEL trips in less than 1 second after trying to crank the motor as trigger through High Output 1 on my PDM32. The MSEL is sending it's PDM kill signal to the PDM, shutting it down.

I reached out to RaceSpec who is MSEL's US distributor and they mentioned there was a batch of MSEL's that have a floating current sensor problem and that they require a zero calibration message to be sent via CAN. I will be sending them my serial # in the morning to determine if mine is one of the affected units.

One other thing to note is that when the MSEL is tripped for overcurrent protection, I can still crank the car by shorting Batt+ to the solenoid hot terminal to bypass the PDM. So I think I have more than one issue with my MSEL since it's not truly isolating the battery.

Just curious if you found a solution. Thanks in advance.

I'm afraid I don't have any good news to share... I tried the calibration CAN message, no deal. Race Spec replaced the isolator for me, I got a new one, same problem. They sent the unit to MSEL and after testing they found out that one of the main power MOSFETs had failed. The back and forth was a little slow, but they were quite willing to help. I provided as much info as I could: PDM logs, ECU logs, CAN logs, oscilloscope logs, wiring diagrams... you name it. But unfortunately we never found out what was the root cause of the issue. At some point they didn't reply and I gave up on following up. In the meantime I replaced the MSEL with a 150a circuit breaker and kept driving. I still suspect that my battery was undersized, and eventually I replaced it with an antigravity ATX-20 and never had cranking problems again. I ordered a Cartek XR to replace the "temporary" circuit breaker, but still haven't gotten around to installing it.

That's a bummer to hear.

My issue solely lies with the MSEL i believe. I was able to bypass it today and the car is cranking and running perfectly. If the MSEL unit just doesn't work right then there is a new ECUMasters one that looks even better than the Cartek version, and honestly probably better than the MSEL as it has a higher continuous current rating.

I'll update this thread when I hear more...

We usually reply within 12hrs (often sooner)

Need Help?

Need help choosing a course?

Experiencing website difficulties?

Or need to contact us for any other reason?