×

Sale ends todayGet 30% off any course (excluding packages)

Ends in --- --- ---

Trigger issue?

Link G4 Plus Software Tutorial

Forum Posts

Courses

Blog

Tech Articles

Discussion and questions related to the course Link G4 Software Tutorial

= Resolved threads

Author
1295 Views

Hi,I have wired a g4 plus atom to a Nissan 260z.it is running a Nissan 280zx intercooler turbo engine L28e 6 cylinder,using the distributor from the same vehicle which has CAS in distributor.I have replaced the disc with a 24/1 disc.I have configured triggers as...trigger mode multi tooth/trigger priority set to trig 1/rpm filtering 1 default. Trigger 1 optical/hall.filtering level 1.trigger pull up on.trigger edge falling.multi tooth pos =cam.tooth count 24.Trigger 2 optical/ hall.filtering level1.pull up on.edge falling.sync mode to cam pulse 1x but I am unable to set base timing as I have no spark.On cranking i do get trig 1 and trig 2 boxes going green.Do you have any suggestions what to check next.thanks

Hi there I'm having same problems with a reluctor type for a 1.6 diahatsu get triggers no errors but no rpm signal or spark ?

With Vr sensors check your voltage threshold.

my old toyota (1994 3sgte) sensor have a voltage of 0.15V below 1000rpm. it goes up rapidly after that

Daniel, can you give more info about your set up, is it a distributor? how many teeth etc. Attach a copy of your tune also.

Hi there it's a diahatsu copen trigger set up and been having nothing but dramas with signalling

Attach a log of it cranking and the tune file.

Hi there the issue was related to the link not knowing the trigger pattern ov the diahatsu engine we used a 24 tooth disc and a TDC sync in the end to run it after exhausting every avenue from distributor and different reluctors modified reluctor apparently I could have sent a trigger scope pattern to link and they could have sent me a updated firmware but time was an issue as it was for an upcoming event that already passed thanks for the offer

There was also issue s with dead times and pulse width info on the Denso injectors it had would b good if link supply's this info in the software as plenty ov injectors get shelfed due to not been able to find this info out and makes it horrible to tune with not knowing the correct values or even a mode that can cycle read impedance ov the injectors to give the data required even the info from injector dynamics is not always correct provided on sizes considering how much it can change the way it runs would b good to have a improvement in this department also as installing a stand alone unit U have a fair few things going on and would b nice to know there exact

Hi there the issue was related to the link not knowing the trigger pattern ov the diahatsu engine we used a 24 tooth disc and a TDC sync in the end to run it after exhausting every avenue from distributor and different reluctors modified reluctor apparently I could have sent a trigger scope pattern to link and they could have sent me a updated firmware but time was an issue as it was for an upcoming event that already passed thanks for the offer

The Daihatsu Copen trigger is well supported in the G4 and G4+ ECU and has been for many years. When I was working there it was a commonly tuned platform in Malaysia and Thailand. Did yours not have the normal 4+1 trigger in the distributor?

There was also issue s with dead times and pulse width info on the Denso injectors it had would b good if link supply's this info in the software as plenty ov injectors get shelfed due to not been able to find this info out and makes it horrible to tune with not knowing the correct values or even a mode that can cycle read impedance ov the injectors to give the data required even the info from injector dynamics is not always correct provided on sizes considering how much it can change the way it runs would b good to have a improvement in this department also as installing a stand alone unit U have a fair few things going on and would b nice to know there exact

Your original post said you had a trigger problem and no RPM or spark, Im not sure how that could be related to injector settings. Regardless, although it is nice to have good characterisation data for your injectors, especially if using the modeled fuel equation - it is hardly essential and is unlikely to effect your tune much at anything but idle.

Hi there yes it had a 4+1 trigger lobes on the dizzy and it would read triggers but not fire the coils at all it had wasted spark coils we also found out later that the atom wouldn't support wasted spark or has troubles running wasted spark and found this out first hand but regardless we had no fire at all from the reluctor cas from copen settings

The injectors was just the next problem we had once we had it running tho I agree it should have only been an issue in idle we were having problems with the stock 160cc injectors leaning out big time and idle wasn't so bad but top end was super lean but ran great on bigger 600cc injectors with the right dead times and pulse width was why I mentioned it I prrobly would have kept stock injectors if I had correct infomation as we origanlly tuned it with a 4 tooth crank trigger due to space but later used a lathe to fit a 24 tooth disc and it changed everything again and was thinking that the injection firing was altered due to the tooth count and noticed the injectors were at low ms due to size as they are bigger as the stock ones prrobly would have been sufficant provided it had a good tooth count eg higher than 4

We usually reply within 12hrs (often sooner)

Need Help?

Need help choosing a course?

Experiencing website difficulties?

Or need to contact us for any other reason?