Sale ends todayGet 30% off any course (excluding packages)

Ends in --- --- ---

My Motec M130 lambda doesn't work !!!

MoTeC M1 Software Tutorial

Forum Posts



Tech Articles

Discussion and questions related to the course MoTeC M1 Software Tutorial

= Resolved threads


Hii, I have problem with my lambda it doesn't work in My M130 software !!!

The sensor working good also the heat coming from the sensor no issue in this. But in the software it's not working !!!

Everything it sims good the setup ( see Attachment ) the wiring all in perfect place but !!!

Need someone can help to solve this issue.

Thank you all,

Attached Files

Hello, have you paid for the feature to be unlocked ? this is extra on most Motec ecus. they will allow you to set up but that is all, contact Motec support for the feature upgrade ,

Regards Ross

The M130 uses the external LTC (Lambda-to-CAN) controller, so no Enable Codes need to be purchased with the M1 ECUS (unlike the hundred series). Your diagnostics indicate you likely have a wiring error.

Have you properly terminated the CAN bus?

I would use the MoTeC CAN Inspector tool (download and install the Motec Utilities) to look at CAN data on the bus. Perhaps your LTC has been programmed for a different address (or possibly the bitrate has been changed). Your M1 looks like it's setup for the default 0x460 / 1 Mbit, which I would expect to be correct.

Has this ever worked, or is this a new installation / harness?

As David has said, the usual cause for this error is a lack of a correctly built CAN Bus, namely it is missing the required terminating resistors. The LTC is a bit of a canary in the coalmine when it comes to the CAN Bus being correctly built, it will be the first device to drop out if there are errors in the bus.

The other areas to check are that you have the correct speed set for all of the devices on the Bus and that you are also using a LTCN (NTK sensor) and not a LTC (Bosch 4.9 sensor)

Hi David , I have tried everything , even changing the sensors and can bus as well and yes this is the first time I am doing this setup. the wiring harness is a new installation. I just don't know what's wrong. it can be something really small but no idea what it is . If someone has a clue please let me know.

Please provide more details on what you tried, and what the results were. For example, did you use CAN Inspector, and see messages from 0x460 on the bus, or did it report something else. Did you try different baud rates (which ones, and did you use CAN inspector at each baud rate)? Did you try swapping CAN Hi and CAN Lo (just to see if that's it, if that doesn't fix it, swap it back right away).

Have you put an ohm meter across CAN Hi and CAN Lo (with the power off) to verify there is a terminating resistor(s) installed? What was the measured resistance.

What is being reported on the following channels?

CAN Bus 1 Diagnostic

Exhaust Lambda (Bank 1/Collector) Diagnostic


Unfortunately, I did not use the tester, and I didn’t change the wires, and also I did not measure the ohms !

I will try these possibilities and I see results.

What I have done is making sure that the wire connections are correct, and also make sure that the Lambda setup entered in the software is correct.

I Also tried to change the sensor with a LTC can bus but the issue is the same noting change !!

Hi BlackRex,

I already attached photos on my first post. You will see what is showing in status.

Receive Error Passive is caused by the M1 not receiving the expected data on the nominated CAN Bus. Selecting LTCN (NTK) when you have a LTC (Bosch 4.9) will cause this, as well as having the incorrect Bus speed on the M1 compared to the Device/s transmitting.

We usually reply within 12hrs (often sooner)

Need Help?

Need help choosing a course?

Experiencing website difficulties?

Or need to contact us for any other reason?