×

Sale ends todayGet 30% off any course (excluding packages)

Ends in --- --- ---

R32 Skyline GTR with M130

MoTeC M1 Software Tutorial

Forum Posts

Courses

Blog

Tech Articles

Discussion and questions related to the course MoTeC M1 Software Tutorial

= Resolved threads

Author
806 Views

I am running an M130 ECU with the USA Drag firmware on my R32 GTR . Is there a way to use an aux output to mimic the TPS input signal for the TPS out signal required for the AWD system?

What does the "TPS out signal required for the AWD system" look like? If it's an analog voltage you are probably out of luck, but it a PWM at a fixed frequency, or a variable frequency then it might be possible.

From what I have found it is 2/3 of the TPS signal voltage that feeds the ECU. On the R34 GTR is a 1:1 of the TPS signal voltage that should also work. Factory spec says the signal is 0.4 to 4V.

I did find this: https://www.haltech.com/product/ht-038001-nissan-attesa-4wd-tps-adaptor/ that might work.

I use a voltage follower (an OP AMP configured at 1:1 gain) and connect the output of the TPS to it. It reproduce the TPS output voltage without messing with the signal to the ECU. Mine is basically the homemade version of the Haltech haha! Even on the R32 I do a 1:1 and never had problems.

I heard some use a PWM table with TPS as an axis to "recreate" the 0-5v signal, but I never done it myself.

Well, I learned something! If it were me, and I was doing it for a customer, I would use that Haltech part.

Thank you guys for the help!

We usually reply within 12hrs (often sooner)

Need Help?

Need help choosing a course?

Experiencing website difficulties?

Or need to contact us for any other reason?