Sale ends todayGet 30% off any course (excluding packages)

Ends in --- --- ---

Rev limit issue !!!!

MoTeC M1 Software Tutorial

Forum Posts



Tech Articles

Discussion and questions related to the course MoTeC M1 Software Tutorial

= Resolved threads


I have an issue regarding of engine speed limits in M1 software. The maximum RPM that I can reach is 3000..!!!

I tried to adjust it but I didn’t found the issue from where does it come!!

My setting for engine speed limit maximum is 6000 !!

Attached Files
  • trim.5857B4F8-CB11-4048-8B90-2EF6510FEDD0.MOV
  • Attachments may only be downloaded by paid Gold members. Read more about becoming a Gold member here.

I don't know about that specific application, but sometimes there is a check/set procedure where the check rpm is half the final value - is there some sort of confirmation check box to select to finally set the RPM limit?

Look at the value of the channel "Engine Speed Limit State". That will show which engine speed limit is active (ie, which one is the lowest). There are about 20 different possibilities. That channel tells you which one is controlling the limit.

BTW 3000 RPM is the hard coded limit used for experimental reference modes. Once someone has run an engine with those modes, and sent MoTeC logged data and Input Capture, they will finalize the reference mode which removes that limit. You get the updates with new firmware system versions.

Your video looks like you are running the engine on a dyno. Is the dyno limiting the engine RPM?


yes there is a field from which you can choose the maximum RPM it’s called “ Engine Speed Limit Maximum “. I’m put the maximum 6000 RPM..!

@ David Ferguson

The channel of Engine speed limit state shows “Maximum” ..!

Regarding for the dyno, I haven’t used it yet because there is a problem of the rev limit that I must solve it and then complete the rest of the settings and start tuning.

The reason I ask about the dyno, is because my Dynapack will default to a speed limit of 3000 RPM if you use the Speed Mode (F3), if I just want to load / test the car, I use Fixed Load Mode (F2).

If you go to the Diagnostics / Ref/Sync do you see any Status/Diags that indicate a problem when you get to 3000 RPM? Is the Fuel Pressure good (no clogged filter)? What happens to the battery voltage when this happens? Have you verified the ignition timing? What is the ignition timing when this happens?

We can keep playing 20 questions, but if you could capture a data log of this happening, and upload it here, we could probably figure out the problem in a few minutes.

how did you get on with this do you still need help if you do please ad your map and a log to this conversation

Thank you all,

@ Ross Honnor

I solved the problem. The issue was the timing it was not perfect, there was different between the number on the software and the timing in the pulley dumper.

And now I’m trying to understand the VTC system how its work and how to tune it..?

(see the attachment)

Attached Files
  • 009B9796-BC69-41E7-B20D-A5079DD34B82.jpeg
  • Attachments may only be downloaded by paid Gold members. Read more about becoming a Gold member here.

Is this a variable valve timing system, or a switched camshaft system? Neither of these systems are configured using an Aux output as they have specific systems to control them.

No, it’s Variable Timing Control

We usually reply within 12hrs (often sooner)

Need Help?

Need help choosing a course?

Experiencing website difficulties?

Or need to contact us for any other reason?