×

Sale ends todayGet 30% off any course (excluding packages)

Ends in --- --- ---

MaxxECU Sport VSS signal and RPM missmatch

Practical Standalone Tuning

Forum Posts

Courses

Blog

Tech Articles

Discussion and questions related to the course Practical Standalone Tuning

= Resolved threads

Author
677 Views

i have wired and tune the ecu to the engine.

it installed on the bmw e36 m52b25

i still use the stock ecu to run ac and abs and vsc

so i piggyback the maxxecu,

problem is the speed signal is moving from 5-20 km/h when i am revving up the engine

i mean the car is in park mode, just rev up the rpm and speed is moving. what did i do wrong ?

VSS is located on the Diff, its a Hall sensor i just tap the signal wire into the DIN2 input from maxecu and have 5v pullup on

second problem is, my RPM reading on the ECU and on the tach is different

tacho showing 7000 , my ecu showing 5500 or so

but its the same untill arround 4K or 4500

whats wrong again,

please help

thanks

All of your problems sound like noise issues, or ground differentials. I would pull out an oscilloscope and look at the signals for clues.

Is there a setting in the MaxxECU for the VSS trigger voltage? What size pullup resistor did you use?

The internal pullups on a Max are 2500ohm, I've rarely had good luck piggybacking shared VSS such as this as factory stuff tends to be relatively noisy.

yeah it was, is there any way to install extra pullups?

on the maxxecu side

hey david, unfortunatelly there is not

We usually reply within 12hrs (often sooner)

Need Help?

Need help choosing a course?

Experiencing website difficulties?

Or need to contact us for any other reason?